summaryrefslogtreecommitdiff
path: root/dev-cpp/doctest/doctest-2.4.11.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-19 06:33:49 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-19 06:33:49 +0000
commit78634f348a30a55cc55606ee1ecde032241ceaeb (patch)
tree528e39df571e37b31bfca1811c69bcc06c4af22f /dev-cpp/doctest/doctest-2.4.11.ebuild
parent434fbe89e81a1fe06d92676be72ab7f862cc3f53 (diff)
gentoo auto-resync : 19:03:2023 - 06:33:49
Diffstat (limited to 'dev-cpp/doctest/doctest-2.4.11.ebuild')
-rw-r--r--dev-cpp/doctest/doctest-2.4.11.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-cpp/doctest/doctest-2.4.11.ebuild b/dev-cpp/doctest/doctest-2.4.11.ebuild
new file mode 100644
index 000000000000..b2da0710bd8a
--- /dev/null
+++ b/dev-cpp/doctest/doctest-2.4.11.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="The fastest feature-rich C++11/14/17/20 single-header testing framework"
+HOMEPAGE="https://github.com/doctest/doctest"
+SRC_URI="https://github.com/doctest/doctest/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+src_prepare() {
+ sed -i '/-Werror/d' scripts/cmake/common.cmake || die
+ cmake_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DDOCTEST_WITH_TESTS=$(usex test)
+ )
+ cmake_src_configure
+}