summaryrefslogtreecommitdiff
path: root/dev-cpp/cppgir/cppgir-0_p20230926.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-08 00:01:40 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-08 00:01:40 +0100
commit607c0755d4f6476e326fb33795df7216a7bcff18 (patch)
treeff1bb6ba6e68dc19d8a94e44b32fd404736d3094 /dev-cpp/cppgir/cppgir-0_p20230926.ebuild
parentf87d83ebb0d6ae5915c4775f762a0b5bceb9b2a5 (diff)
gentoo auto-resync : 08:10:2023 - 00:01:40
Diffstat (limited to 'dev-cpp/cppgir/cppgir-0_p20230926.ebuild')
-rw-r--r--dev-cpp/cppgir/cppgir-0_p20230926.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-cpp/cppgir/cppgir-0_p20230926.ebuild b/dev-cpp/cppgir/cppgir-0_p20230926.ebuild
new file mode 100644
index 000000000000..62c582bf37fc
--- /dev/null
+++ b/dev-cpp/cppgir/cppgir-0_p20230926.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake flag-o-matic
+
+DESCRIPTION="GObject-Introspection C++ binding wrapper generator"
+HOMEPAGE="https://gitlab.com/mnauw/cppgir"
+
+MY_PV="4c16bffe646af52b7112785cda8112d761f95860"
+SRC_URI="https://gitlab.com/mnauw/cppgir/-/archive/${MY_PV}/cppgir-${MY_PV}.tar.bz2 -> ${P}.tar.bz2"
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"
+IUSE="doc test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-libs/boost:=
+ dev-libs/libfmt:=
+"
+DEPEND="${RDEPEND}
+ dev-cpp/expected-lite
+"
+BDEPEND="
+ doc? ( app-text/ronn-ng )
+ test? ( dev-libs/glib )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_DOC=$(usex doc)
+ -DBUILD_TESTING=$(usex test)
+ -DBUILD_EXAMPLES=no
+ -DINTERNAL_EXPECTED=no
+ )
+
+ append-cppflags \
+ -UDEFAULT_GIRPATH \
+ -DDEFAULT_GIRPATH="${EPREFIX}/usr/share:${EPREFIX}/usr/local/share"
+
+ cmake_src_configure
+}