summaryrefslogtreecommitdiff
path: root/dev-cpp/cctz/cctz-2.3_p20230228.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-03 01:32:36 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-03 01:32:36 +0000
commit92b7880bd28edc591d46c65b2242bbad6106fb39 (patch)
tree0b5c4ff09cb0e02c310fe6c37b2bf391cf932c80 /dev-cpp/cctz/cctz-2.3_p20230228.ebuild
parent7228e7507f59b8f0982c3a68cc5ba8ea35ce1a76 (diff)
gentoo auto-resync : 03:03:2023 - 01:32:36
Diffstat (limited to 'dev-cpp/cctz/cctz-2.3_p20230228.ebuild')
-rw-r--r--dev-cpp/cctz/cctz-2.3_p20230228.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-cpp/cctz/cctz-2.3_p20230228.ebuild b/dev-cpp/cctz/cctz-2.3_p20230228.ebuild
new file mode 100644
index 000000000000..448b7f921122
--- /dev/null
+++ b/dev-cpp/cctz/cctz-2.3_p20230228.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="C++ library for dealing with time zones and time conversion"
+HOMEPAGE="https://github.com/google/cctz"
+MY_COMMIT="3803b96130934f48b1fc1d47c5da5f542949c4b0"
+SRC_URI="https://github.com/google/cctz/archive/${MY_COMMIT}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${MY_COMMIT}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ test? (
+ dev-cpp/gtest
+ )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTING=$(usex test)
+ -DBUILD_BENCHMARK=OFF
+ )
+ cmake_src_configure
+}