summaryrefslogtreecommitdiff
path: root/dev-cpp/catch/catch-1.12.2-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-15 12:15:20 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-15 12:15:20 +0100
commit4f064d2f2d61a575a6e418623bd2dc3c8599ad13 (patch)
treeb4969a550417293bfcb239af37c68d8578a706a6 /dev-cpp/catch/catch-1.12.2-r2.ebuild
parent78f392693b4d21958c3f9e73171c7c65cb437bb5 (diff)
gentoo auto-resync : 15:08:2023 - 12:15:20
Diffstat (limited to 'dev-cpp/catch/catch-1.12.2-r2.ebuild')
-rw-r--r--dev-cpp/catch/catch-1.12.2-r2.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-cpp/catch/catch-1.12.2-r2.ebuild b/dev-cpp/catch/catch-1.12.2-r2.ebuild
new file mode 100644
index 000000000000..d2044848fd4b
--- /dev/null
+++ b/dev-cpp/catch/catch-1.12.2-r2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/catchorg/Catch2.git"
+ EGIT_BRANCH="Catch1.x"
+else
+ MY_P=${PN^}-${PV}
+ SRC_URI="https://github.com/catchorg/Catch2/archive/v${PV}.tar.gz -> ${MY_P}.tar.gz"
+ KEYWORDS="amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc x86"
+
+ S="${WORKDIR}/${PN^}2-${PV}"
+fi
+
+DESCRIPTION="Modern C++ header-only framework for unit-tests"
+HOMEPAGE="https://github.com/catchorg/Catch2"
+
+LICENSE="Boost-1.0"
+SLOT="1"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.12.2-glibc-2.34-sigstksz.patch
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DNO_SELFTEST=$(usex !test)
+ )
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+ dodoc -r docs/.
+}