summaryrefslogtreecommitdiff
path: root/dev-cpp/benchmark/benchmark-1.8.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-24 22:45:43 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-24 22:45:43 +0000
commit3f6b99c9f74a0a7bfa2e18f0a7bc7057739cc00b (patch)
treee56393aac5dcc184833b4e155d45468003757d48 /dev-cpp/benchmark/benchmark-1.8.2.ebuild
parentb0fd0bc5c186e99078ed8d07146e8c14f1089639 (diff)
gentoo auto-resync : 24:01:2024 - 22:45:43
Diffstat (limited to 'dev-cpp/benchmark/benchmark-1.8.2.ebuild')
-rw-r--r--dev-cpp/benchmark/benchmark-1.8.2.ebuild34
1 files changed, 0 insertions, 34 deletions
diff --git a/dev-cpp/benchmark/benchmark-1.8.2.ebuild b/dev-cpp/benchmark/benchmark-1.8.2.ebuild
deleted file mode 100644
index e87f23f14a3f..000000000000
--- a/dev-cpp/benchmark/benchmark-1.8.2.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake flag-o-matic
-
-DESCRIPTION="A microbenchmark support library"
-HOMEPAGE="https://github.com/google/benchmark"
-SRC_URI="https://github.com/google/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm arm64 ~hppa ~loong ppc ppc64 ~riscv x86"
-IUSE="debug doc test"
-RESTRICT="!test? ( test )"
-
-BDEPEND="doc? ( app-text/doxygen )
- test? ( >=dev-cpp/gtest-1.11.0 )"
-
-src_configure() {
- local mycmakeargs=(
- -DBENCHMARK_ENABLE_ASSEMBLY_TESTS=OFF
- -DBENCHMARK_ENABLE_DOXYGEN=$(usex doc)
- -DBENCHMARK_ENABLE_GTEST_TESTS=$(usex test)
- -DBENCHMARK_ENABLE_TESTING=$(usex test)
- -DBENCHMARK_ENABLE_WERROR=OFF
- -DBENCHMARK_USE_BUNDLED_GTEST=OFF
- )
-
- use debug || append-cppflags -DNDEBUG
-
- cmake_src_configure
-}