summaryrefslogtreecommitdiff
path: root/dev-cpp/benchmark/benchmark-1.5.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
commit9ee6d97c2883d42f204a533a8bc1f4562df778fb (patch)
treeb690ddc0ca30f1472887edbb0b8313629bfcbbb2 /dev-cpp/benchmark/benchmark-1.5.1.ebuild
parentb17a3ef12038de50228bade1f05502c74e135321 (diff)
gentoo resync : 16.09.2020
Diffstat (limited to 'dev-cpp/benchmark/benchmark-1.5.1.ebuild')
-rw-r--r--dev-cpp/benchmark/benchmark-1.5.1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-cpp/benchmark/benchmark-1.5.1.ebuild b/dev-cpp/benchmark/benchmark-1.5.1.ebuild
new file mode 100644
index 000000000000..c64fe45b19ae
--- /dev/null
+++ b/dev-cpp/benchmark/benchmark-1.5.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="A microbenchmark support library"
+HOMEPAGE="https://github.com/google/benchmark"
+SRC_URI="https://github.com/google/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBENCHMARK_ENABLE_TESTING=$(usex test)
+ -DBENCHMARK_ENABLE_GTEST_TESTS=OFF
+ -DBENCHMARK_ENABLE_ASSEMBLY_TESTS=OFF
+ )
+
+ cmake_src_configure
+}