summaryrefslogtreecommitdiff
path: root/dev-cpp/asio
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-cpp/asio
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-cpp/asio')
-rw-r--r--dev-cpp/asio/Manifest5
-rw-r--r--dev-cpp/asio/asio-1.10.8.ebuild45
-rw-r--r--dev-cpp/asio/asio-1.12.1.ebuild48
-rw-r--r--dev-cpp/asio/metadata.xml11
4 files changed, 109 insertions, 0 deletions
diff --git a/dev-cpp/asio/Manifest b/dev-cpp/asio/Manifest
new file mode 100644
index 000000000000..786d7aa44037
--- /dev/null
+++ b/dev-cpp/asio/Manifest
@@ -0,0 +1,5 @@
+DIST asio-1.10.8.tar.bz2 1270332 BLAKE2B 97e4a6a7c8b4562f10af1d122e9b08c12d567fd0447d1951a907f47f77832dcd42df4cb9b5b392feaaa2ea7c79d8bedfcf12e3052957ec012d8bb6b4d1347eb5 SHA512 d870686d2b19bec9925c311f2f0fd370e9797bbad252176a80a998f9c322ecd502b5081826105712e7caf87c03c3e6b70a0e219019e5bff46077d6e8c3c6db09
+DIST asio-1.12.1.tar.bz2 1444246 BLAKE2B d59b47a4dedd8d0892ace6d93c371cb02e16534b41bd490a945785526ad0a11bd6cb15f205bc5702b5a14780876bd92041bffac2898658b40c78ea27d4f37b14 SHA512 a994e1ee9a252d9f8cc2ada0915a9866eeebdd2b1d9a8fd50fa8db06d5ee6277f44a0f83c79f46f939adca43e02373ffee78ff6b1d6ae1798dcb1cd6d56dc568
+EBUILD asio-1.10.8.ebuild 895 BLAKE2B 6f3de4ae224765cd3af5863fabb60f22a9ee060839c64cf6c2269f1cad57229914da5351cf90750522faa99fb362021ccc76fb8ea293859aef3e7465081df761 SHA512 648aa85f02271260fdc7c1ba7d6093c5dba3a172e4585d7d8f8e70dedc111d2bbd57093ebb3e8fc2a85008e5981b17a1861e356efd6102689bdc17f015e75e5a
+EBUILD asio-1.12.1.ebuild 966 BLAKE2B 9b0e88cbc1ed5221620b8822e259764d606be3b40e4d0874f45d714479488902b6e9707433679a4a5ce966bcbb5ed36afa583b6fbbf5f1405e09f6df0daf7c77 SHA512 42f3803e7b5efaba364e35b83420eaefbe86856b1722b3f4b1af4b4404c6bfe7fb2e29b10d5f537eec6d24bcd8b53d26b123e4dff515d1fc7e2903b7ee98f718
+MISC metadata.xml 323 BLAKE2B 91aaf7041f894ff16bd10ee476a29a5da16f275a7791d484abddd8dae337df92293e16b4b2e5938f2418e6f183375e9ec6b38697c9be7207c64a340d3388da94 SHA512 e0633d245fa2f07cca452fca7937a2fbb64b977cae0c291abb52b0a9cc3af1e84fbad6f15135baa9835648959efa4fb68cdb3ec612efcfe856da485658f55595
diff --git a/dev-cpp/asio/asio-1.10.8.ebuild b/dev-cpp/asio/asio-1.10.8.ebuild
new file mode 100644
index 000000000000..6510f168fcde
--- /dev/null
+++ b/dev-cpp/asio/asio-1.10.8.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Asynchronous Network Library"
+HOMEPAGE="http://asio.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${PN}/${P}.tar.bz2"
+
+LICENSE="Boost-1.0"
+SLOT="0"
+KEYWORDS="alpha amd64 ~arm ~arm64 ~hppa ia64 ppc ppc64 sparc x86"
+IUSE="doc examples ssl test"
+
+RDEPEND="dev-libs/boost
+ ssl? ( dev-libs/openssl:0= )"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+
+ if ! use test; then
+ # Don't build nor install any examples or unittests
+ # since we don't have a script to run them
+ cat > src/Makefile.in <<-EOF || die
+ all:
+
+ install:
+
+ clean:
+ EOF
+ fi
+}
+
+src_install() {
+ use doc && local HTML_DOCS=( doc/. )
+ default
+
+ if use examples; then
+ # Get rid of the object files
+ emake clean
+ dodoc -r src/examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}
diff --git a/dev-cpp/asio/asio-1.12.1.ebuild b/dev-cpp/asio/asio-1.12.1.ebuild
new file mode 100644
index 000000000000..9a8a2d25af2c
--- /dev/null
+++ b/dev-cpp/asio/asio-1.12.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Asynchronous Network Library"
+HOMEPAGE="http://asio.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${PN}/${P}.tar.bz2"
+
+LICENSE="Boost-1.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc examples libressl ssl test"
+
+RDEPEND="dev-libs/boost
+ ssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ )"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+
+ if ! use test; then
+ # Don't build nor install any examples or unittests
+ # since we don't have a script to run them
+ cat > src/Makefile.in <<-EOF || die
+ all:
+
+ install:
+
+ clean:
+ EOF
+ fi
+}
+
+src_install() {
+ use doc && local HTML_DOCS=( doc/. )
+ default
+
+ if use examples; then
+ # Get rid of the object files
+ emake clean
+ dodoc -r src/examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}
diff --git a/dev-cpp/asio/metadata.xml b/dev-cpp/asio/metadata.xml
new file mode 100644
index 000000000000..73002f23cba4
--- /dev/null
+++ b/dev-cpp/asio/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>cpp@gentoo.org</email>
+ <name>Gentoo C++ Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">asio</remote-id>
+ </upstream>
+</pkgmetadata>