summaryrefslogtreecommitdiff
path: root/dev-cpp/argparse/argparse-2.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-26 03:54:55 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-26 03:54:55 +0100
commit2ecd7994be1409f2a65bfca700904d2a78fd7bbe (patch)
tree0248ea4d4f411ea88c27470c15ebc725bb04baa1 /dev-cpp/argparse/argparse-2.6.ebuild
parentc22e93ab35a8cb604c41623a7b2cda059c462b70 (diff)
gentoo auto-resync : 26:10:2022 - 03:54:55
Diffstat (limited to 'dev-cpp/argparse/argparse-2.6.ebuild')
-rw-r--r--dev-cpp/argparse/argparse-2.6.ebuild29
1 files changed, 0 insertions, 29 deletions
diff --git a/dev-cpp/argparse/argparse-2.6.ebuild b/dev-cpp/argparse/argparse-2.6.ebuild
deleted file mode 100644
index e273fd49b506..000000000000
--- a/dev-cpp/argparse/argparse-2.6.ebuild
+++ /dev/null
@@ -1,29 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake
-
-DESCRIPTION="Argument Parser for Modern C++"
-HOMEPAGE="https://github.com/p-ranav/argparse"
-SRC_URI="https://github.com/p-ranav/argparse/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-src_configure() {
- local mycmakeargs=(
- -DARGPARSE_BUILD_TESTS=$(usex test)
- )
-
- cmake_src_configure
-}
-
-src_test() {
- cd "${BUILD_DIR}"/test || die
- ./tests || die
-}