summaryrefslogtreecommitdiff
path: root/dev-cpp/abseil-cpp/abseil-cpp-20230802.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-06-14 00:09:04 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-06-14 00:09:04 +0100
commit5e41a38157bb40e8513e8e34426e85faba672fe7 (patch)
tree38e9365afd56c161d0e970ddf5420b2585130587 /dev-cpp/abseil-cpp/abseil-cpp-20230802.0.ebuild
parent0ebcd2cbf178600b5eb36b2f24cdbb3d2f4a9000 (diff)
gentoo auto-resync : 14:06:2024 - 00:09:04
Diffstat (limited to 'dev-cpp/abseil-cpp/abseil-cpp-20230802.0.ebuild')
-rw-r--r--dev-cpp/abseil-cpp/abseil-cpp-20230802.0.ebuild63
1 files changed, 0 insertions, 63 deletions
diff --git a/dev-cpp/abseil-cpp/abseil-cpp-20230802.0.ebuild b/dev-cpp/abseil-cpp/abseil-cpp-20230802.0.ebuild
deleted file mode 100644
index 8efabfde0a90..000000000000
--- a/dev-cpp/abseil-cpp/abseil-cpp-20230802.0.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 2020-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{10..12} )
-
-inherit cmake-multilib python-any-r1
-
-DESCRIPTION="Abseil Common Libraries (C++), LTS Branch"
-HOMEPAGE="https://abseil.io/"
-SRC_URI="https://github.com/abseil/abseil-cpp/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0/${PV%%.*}"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~sparc ~x86"
-IUSE="test"
-
-DEPEND=""
-RDEPEND="${DEPEND}"
-
-BDEPEND="
- ${PYTHON_DEPS}
- test? (
- >=dev-cpp/gtest-1.13.0
- sys-libs/timezone-data
- )
-"
-
-RESTRICT="!test? ( test )"
-PATCHES=( "${FILESDIR}/${PN}-20230802.0-sdata-tests.patch" )
-
-src_prepare() {
- cmake_src_prepare
-
- # un-hardcode abseil compiler flags
- sed -i \
- -e '/"-maes",/d' \
- -e '/"-msse4.1",/d' \
- -e '/"-mfpu=neon"/d' \
- -e '/"-march=armv8-a+crypto"/d' \
- absl/copts/copts.py || die
-
- # now generate cmake files
- python_fix_shebang absl/copts/generate_copts.py
- absl/copts/generate_copts.py || die
-}
-
-multilib_src_configure() {
- local mycmakeargs=(
- # We use -std=c++14 here so that abseil-cpp's string_view is used
- # See the discussion in https://github.com/gentoo/gentoo/pull/32281.
- -DCMAKE_CXX_STANDARD=14
- -DABSL_ENABLE_INSTALL=TRUE
- -DABSL_USE_EXTERNAL_GOOGLETEST=ON
- -DABSL_PROPAGATE_CXX_STD=TRUE
- -DABSL_BUILD_TEST_HELPERS=$(usex test ON OFF)
- -DABSL_BUILD_TESTING=$(usex test ON OFF)
- $(usex test -DBUILD_TESTING=ON '') # intentional usex, it used both variables for tests.
- )
-
- cmake_src_configure
-}