summaryrefslogtreecommitdiff
path: root/dev-ada/gps-bin
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ada/gps-bin
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ada/gps-bin')
-rw-r--r--dev-ada/gps-bin/Manifest3
-rw-r--r--dev-ada/gps-bin/gps-bin-2016.ebuild65
-rw-r--r--dev-ada/gps-bin/metadata.xml22
3 files changed, 90 insertions, 0 deletions
diff --git a/dev-ada/gps-bin/Manifest b/dev-ada/gps-bin/Manifest
new file mode 100644
index 000000000000..b1547d98affc
--- /dev/null
+++ b/dev-ada/gps-bin/Manifest
@@ -0,0 +1,3 @@
+DIST gnat-gpl-2016-x86_64-linux-bin.tar.gz 372813330 BLAKE2B a0374ad730ae275aaedcf5663c30f8e0221af32f14391fe87a3ce0630d4498a1e90671c02830d62f78857571a5a521af91f6db409a7b3c367c7b0f059571eefd SHA512 5115ac3be0badc5125ee048a98230f18363d72107da3325ce602c0e618cee2e3646a0decc00a2388f14bc61bfed51dd0622f365f5f7ee8b0cec2187ebcf8e075
+EBUILD gps-bin-2016.ebuild 1500 BLAKE2B 32b2a084ea499feedd0b4933030d0d788bcff87285b28ef8c7a876a533678bf5672d42c2dfe6ac66fb88afbcbc78f39d526d9d29c5b723dc2d283fb3b7e30a3a SHA512 a50cfed20c261764fea8e2311a61511d195bbbc83fda86b0da74e3aef4883c38426e633951a3b817e051cf0786b54f3556fff6cd38e6c6c3a6a63a68f2a9ef8f
+MISC metadata.xml 1020 BLAKE2B 31b305e3aa3f0c87a449779685bc366e34b4c8f63989f5180feaa26df90322b276081b4bb2e10c23c3e7d139dc9b96e48c42ef7145646bcd1ef0ec6c106a06fb SHA512 b5c9fcae1f4d37762f6bb0457b245c60b3b96449f68b9fbd0f4c1d919174c18d3c2a82c26e1d0ca02177cbc2480125aac3ff47b61c2404571e85d0588ca9644e
diff --git a/dev-ada/gps-bin/gps-bin-2016.ebuild b/dev-ada/gps-bin/gps-bin-2016.ebuild
new file mode 100644
index 000000000000..f112dba176b4
--- /dev/null
+++ b/dev-ada/gps-bin/gps-bin-2016.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit toolchain-funcs
+
+MY_P=gnat-gpl-2016-x86_64-linux-bin
+
+DESCRIPTION="The GNAT Programming Studio"
+HOMEPAGE="http://libre.adacore.com/tools/gps/"
+SRC_URI="http://mirrors.cdn.adacore.com/art/5739cefdc7a447658e0b016b -> ${MY_P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ dev-ada/gnatcoll[gnat_2016,iconv,postgres,projects,readline,sqlite]
+ dev-libs/atk
+ dev-libs/glib
+ dev-libs/gobject-introspection
+ dev-libs/libffi
+ media-libs/fontconfig
+ media-libs/freetype
+ sys-devel/llvm
+ sys-devel/clang
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf
+ x11-libs/gtk+
+ x11-libs/pango
+ x11-themes/adwaita-icon-theme
+ x11-themes/hicolor-icon-theme"
+
+S="${WORKDIR}"/${MY_P}
+
+src_compile() {
+ :
+}
+
+src_install() {
+ GCC_PV=4.9.4
+ GCC=gcc-${GCC_PV}
+ GNATLS=gnatls-${GCC_PV}
+ GNAT=gnatt-${GCC_PV}
+ GNATMAKE=gnatmake-${GCC_PV}
+ into /opt/${P}
+ dobin bin/gps_exe
+ dobin bin/gps_cli
+ insinto /opt/${P}/share
+ doins -r share/doc
+ doins -r share/examples
+ doins -r share/gpr
+ doins -r share/gprconfig
+ doins -r share/gps
+ doins -r share/themes
+ insinto /opt/${P}/lib/
+ doins -r lib/python2.7
+ dosym ../../../usr/bin/gnatinspect /opt/${P}/bin/gnatinspect
+ dosym ../../../usr/bin/${GNATLS} /opt/${P}/bin/gnatls
+ dosym ../../../usr/bin/${GNATMAKE} /opt/${P}/bin/gnatmake
+ dosym ../../../usr/bin/${GNAT} /opt/${P}/bin/gnat
+ dosym ../../opt/${P}/bin/gps_exe /usr/bin/gps
+}
diff --git a/dev-ada/gps-bin/metadata.xml b/dev-ada/gps-bin/metadata.xml
new file mode 100644
index 000000000000..5c70b5a1629a
--- /dev/null
+++ b/dev-ada/gps-bin/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>tupone@gentoo.org</email>
+ <name>Tupone Alfredo</name>
+ </maintainer>
+ <longdescription lang="en">
+ GPS, the GNAT Programming Studio, is a cutting-edge Free Software IDE
+ that streamlines the interaction between developers and their software.
+ With its intuitive interface, GPS is easy to use, simplifying source
+ navigation and highlighting the fundamental ideas in the program.
+
+ By displaying core application structures, such as call graphs, program
+ entity graphs, and project dependencies, GPS facilitates the
+ development of systems. GPS helps construct reliable code while
+ providing the same interface and behavior across a variety of
+ platforms. Designed by programmers for programmers, GPS is a new kind
+ of IDE that offers the experience of designing software in a uniquely
+ comfortable environment.
+ </longdescription>
+</pkgmetadata>