summaryrefslogtreecommitdiff
path: root/dev-ada/e3-core/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
commit2771f79232c273bc2a57d23bf335dd81ccf6af28 (patch)
treec8af0fd04194aed03cf067d44e53c7edd3e9ab84 /dev-ada/e3-core/files
parente9d044d4b9b71200a96adfa280848858c0f468c9 (diff)
gentoo resync : 05.12.2021
Diffstat (limited to 'dev-ada/e3-core/files')
-rw-r--r--dev-ada/e3-core/files/e3-core-22.1.0-distro.patch30
-rw-r--r--dev-ada/e3-core/files/e3-core-22.1.0-test.patch28
2 files changed, 58 insertions, 0 deletions
diff --git a/dev-ada/e3-core/files/e3-core-22.1.0-distro.patch b/dev-ada/e3-core/files/e3-core-22.1.0-distro.patch
new file mode 100644
index 000000000000..05942a8f8e7d
--- /dev/null
+++ b/dev-ada/e3-core/files/e3-core-22.1.0-distro.patch
@@ -0,0 +1,30 @@
+--- a/src/e3/os/platform.py 2021-11-23 08:50:05.077801145 +0100
++++ b/src/e3/os/platform.py 2021-11-23 08:50:40.646227489 +0100
+@@ -85,12 +85,12 @@
+
+ # Fetch linux distribution info on linux OS
+ if cls.uname.system == "Linux": # linux-only
+- import ld
++ import distro
+
+ cls.ld_info = {
+- "name": ld.name(),
+- "major_version": ld.major_version(),
+- "version": ld.version(),
++ "name": distro.name(),
++ "major_version": distro.major_version(),
++ "version": distro.version(),
+ }
+
+ # Fetch network interfaces
+--- a/setup.py 2021-11-23 20:36:57.056478696 +0100
++++ b/setup.py 2021-11-23 20:36:03.371303043 +0100
+@@ -18,7 +18,7 @@
+ platform_string = ":sys_platform=='%s'" % p
+ extras_require[platform_string] = ["psutil"]
+ if p in ("linux", "linux2"):
+- extras_require[platform_string].append("ld")
++ extras_require[platform_string].append("distro")
+
+ # Get e3 version from the VERSION file.
+ version_file = os.path.join(os.path.dirname(__file__), "VERSION")
diff --git a/dev-ada/e3-core/files/e3-core-22.1.0-test.patch b/dev-ada/e3-core/files/e3-core-22.1.0-test.patch
new file mode 100644
index 000000000000..84250e1379c8
--- /dev/null
+++ b/dev-ada/e3-core/files/e3-core-22.1.0-test.patch
@@ -0,0 +1,28 @@
+--- a/tests/tests_e3/main/main_test.py 2021-11-23 21:43:12.376707596 +0100
++++ b/tests/tests_e3/main/main_test.py 2021-11-23 21:45:08.653856916 +0100
+@@ -15,6 +15,7 @@
+ )
+
+
++@pytest.mark.xfail(reason="does not work on sandbox")
+ def test_main_config():
+ os.environ["E3_CONFIG"] = "e3.toml"
+ assert "pretty: True" in e3.os.process.Run(["e3", "--show-config"]).out
+--- a/tests/tests_e3/sys/main_test.py 2021-11-23 21:51:32.633747623 +0100
++++ b/tests/tests_e3/sys/main_test.py 2021-11-23 21:51:43.977567183 +0100
+@@ -10,6 +10,7 @@
+ import pytest
+
+
++@pytest.mark.xfail(reason="does not work on sandbox")
+ def test_filtering_import():
+ script = """
+ import a, b, c
+--- a/tests/tests_e3/system/main_test.py 2021-11-23 22:16:33.776844819 +0100
++++ b/tests/tests_e3/system/main_test.py 2021-11-23 22:17:38.292817661 +0100
+@@ -4,5 +4,3 @@
+
+ def test_main():
+ e3_tool = e3.sys.python_script("e3")
+- assert e3.os.process.Run(e3_tool + ["--version"]).status == 0
+- assert "Everything OK!" in e3.os.process.Run(e3_tool + ["--check"]).out