summaryrefslogtreecommitdiff
path: root/dev-ada/e3-core/e3-core-22.2.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-06 03:08:16 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-06 03:08:16 +0000
commit7bf9e3db263e64d6cbc306440a7f3c44e551bb13 (patch)
tree69c4367f0e4c2350bfb04e76bb55bfc2e353b052 /dev-ada/e3-core/e3-core-22.2.0.ebuild
parent7ac0e89e1c8027ed5be76f6005e8cb52b1e5d484 (diff)
gentoo auto-resync : 06:12:2022 - 03:08:16
Diffstat (limited to 'dev-ada/e3-core/e3-core-22.2.0.ebuild')
-rw-r--r--dev-ada/e3-core/e3-core-22.2.0.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/dev-ada/e3-core/e3-core-22.2.0.ebuild b/dev-ada/e3-core/e3-core-22.2.0.ebuild
new file mode 100644
index 000000000000..34a0061cc70f
--- /dev/null
+++ b/dev-ada/e3-core/e3-core-22.2.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8,9,10} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1 toolchain-funcs
+
+DESCRIPTION="Ease the development of portable automated build systems"
+HOMEPAGE="https://www.adacore.com/"
+SRC_URI="https://github.com/AdaCore/${PN}/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="test"
+
+RDEPEND="dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/stevedore[${PYTHON_USEDEP}]
+ dev-python/distro[${PYTHON_USEDEP}]
+ dev-python/tqdm[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/requests-toolbelt[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/tomlkit[${PYTHON_USEDEP}]
+ !app-editors/e3"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ test? (
+ dev-python/httpretty[${PYTHON_USEDEP}]
+ dev-vcs/subversion
+ dev-python/mock[${PYTHON_USEDEP}]
+ )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-22.1.0-distro.patch
+ "${FILESDIR}"/${PN}-22.1.0-test.patch
+)
+
+distutils_enable_tests pytest
+
+python_compile() {
+ distutils-r1_python_compile
+ find "${BUILD_DIR}" -name '*.pth' -delete || die
+}
+
+src_compile() {
+ local PLATFORM=x86_64-linux
+ rm src/e3/os/data/rlimit* || die
+ $(tc-getCC) ${CFLAGS} -o src/e3/os/data/rlimit-${PLATFORM} tools/rlimit/rlimit.c ${LDFLAGS}
+ distutils-r1_src_compile
+}