summaryrefslogtreecommitdiff
path: root/dev-ada/aunit/aunit-2021.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-15 11:54:41 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-15 11:54:41 +0000
commit046c3c0984fd20387a9f86cdd0842fd81e70d94f (patch)
treecc10a34db3ff175a68ebd1f398672156c9aad0e9 /dev-ada/aunit/aunit-2021.ebuild
parentbdc9b55c978e3939e16252e66e83950cbecbf77c (diff)
gentoo auto-resync : 15:01:2023 - 11:54:40
Diffstat (limited to 'dev-ada/aunit/aunit-2021.ebuild')
-rw-r--r--dev-ada/aunit/aunit-2021.ebuild48
1 files changed, 0 insertions, 48 deletions
diff --git a/dev-ada/aunit/aunit-2021.ebuild b/dev-ada/aunit/aunit-2021.ebuild
deleted file mode 100644
index 2e1185171fad..000000000000
--- a/dev-ada/aunit/aunit-2021.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-ADA_COMPAT=( gnat_2021 )
-inherit ada multiprocessing
-
-MYP=${P}-${PV}0518-19DC5-src
-ID=c8eadafc40c016859e127cd0e82411fcd8f3e749
-ADAMIRROR=https://community.download.adacore.com/v1
-
-DESCRIPTION="Ada unit testing framework"
-HOMEPAGE="http://libre.adacore.com/tools/aunit/"
-SRC_URI="${ADAMIRROR}/${ID}?filename=${MYP}.tar.gz -> ${MYP}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE=""
-
-RDEPEND="${ADA_DEPS}"
-DEPEND="${RDEPEND}
- dev-ada/gprbuild[${ADA_USEDEP}]"
-
-REQUIRED_USE="${ADA_REQUIRED_USE}"
-
-S="${WORKDIR}"/${MYP}
-
-PATCHES=( "${FILESDIR}"/${PN}-2016-gentoo.patch )
-
-src_compile() {
- emake GPRBUILD="gprbuild -j$(makeopts_jobs) -v"
-}
-
-src_install() {
- emake INSTALL="${D}"/usr install
- einstalldocs
- mv "${D}"/usr/share/doc/${PN}/* "${D}"/usr/share/doc/${PF}/ || die
- rmdir "${D}"/usr/share/doc/${PN} || die
- mv "${D}"/usr/share/examples/${PN} "${D}"/usr/share/doc/${PF}/examples || die
- rmdir "${D}"/usr/share/examples || die
- rm -r "${D}"/usr/share/gpr/manifests || die
-}
-
-src_test() {
- emake PROJECT_PATH_ARG="ADA_PROJECT_PATH=$(pwd)/lib/gnat" -C test
-}