summaryrefslogtreecommitdiff
path: root/backup/reoback/reoback-1.0_p3-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:12:15 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:12:15 +0100
commit3f7826d8856457be233edea5999a25e374f54625 (patch)
tree7b49d251a79cf55d5e29ceb9af99308b5f037628 /backup/reoback/reoback-1.0_p3-r1.ebuild
parent6deea6f9112b20068bdb8e82f049e28508efac83 (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'backup/reoback/reoback-1.0_p3-r1.ebuild')
-rw-r--r--backup/reoback/reoback-1.0_p3-r1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/backup/reoback/reoback-1.0_p3-r1.ebuild b/backup/reoback/reoback-1.0_p3-r1.ebuild
new file mode 100644
index 000000000000..5333073fa6b1
--- /dev/null
+++ b/backup/reoback/reoback-1.0_p3-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="Reoback Backup Solution"
+HOMEPAGE="http://reoback.sourceforge.net/"
+SRC_URI="mirror://sourceforge/reoback/reoback-${PV/_p/_r}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/perl-5.6.1"
+DEPEND=">=app-arch/tar-1.13"
+
+S=${WORKDIR}/${PN}-${PV/_*}
+
+src_prepare() {
+ ecvs_clean
+ sed \
+ -e '/^config=/s:=.*:=/etc/reoback/settings.conf:' \
+ -e '/^reoback=/s:=.*:=/usr/sbin/reoback.pl:' \
+ -i run_reoback.sh || die
+}
+
+src_install() {
+ dosbin reoback.pl
+ insinto /etc/reoback
+ doins conf/*
+ fperms o-x /usr/sbin/reoback.pl
+ insinto /etc/cron.daily
+ newins run_reoback.sh reoback
+ dodoc docs/{BUGS,CHANGES,INSTALL,MANUALS,README,TODO}
+}
+
+pkg_postinst() {
+ elog "Reoback can now be activated by simply configuring the files in"
+ elog "/etc/reoback and then doing: chmod +x /etc/cron.daily/reoback"
+}