summaryrefslogtreecommitdiff
path: root/backup/hdup/hdup-2.0.14.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:12:15 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:12:15 +0100
commit3f7826d8856457be233edea5999a25e374f54625 (patch)
tree7b49d251a79cf55d5e29ceb9af99308b5f037628 /backup/hdup/hdup-2.0.14.ebuild
parent6deea6f9112b20068bdb8e82f049e28508efac83 (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'backup/hdup/hdup-2.0.14.ebuild')
-rw-r--r--backup/hdup/hdup-2.0.14.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/backup/hdup/hdup-2.0.14.ebuild b/backup/hdup/hdup-2.0.14.ebuild
new file mode 100644
index 000000000000..87d941b00336
--- /dev/null
+++ b/backup/hdup/hdup-2.0.14.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Hdup is backup program using tar, find, gzip/bzip2, mcrypt and ssh"
+HOMEPAGE="http://www.miek.nl/projects/hdup2/index.html"
+SRC_URI="http://www.miek.nl/projects/${PN}2/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="crypt"
+
+CDEPEND="
+ app-arch/bzip2
+ app-arch/gzip
+ app-arch/tar
+ >=dev-libs/glib-2.0"
+RDEPEND="
+ ${CDEPEND}
+ net-misc/openssh
+ sys-apps/coreutils
+ sys-apps/findutils
+ crypt? ( app-crypt/mcrypt )"
+DEPEND="
+ ${CDEPEND}
+ virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}"/${PN}-2.0.14-fix-build-system.patch )
+
+src_install() {
+ HTML_DOCS=( doc/FAQ.html )
+ default
+ dodoc Credits
+
+ insinto /usr/share/${PN}
+ doins -r contrib examples
+}
+
+pkg_postinst() {
+ elog "Now edit your /etc/hdup/${PN}.conf to configure your backups."
+ elog "You can also check included examples and contrib, see /usr/share/${PN}/."
+}