summaryrefslogtreecommitdiff
path: root/app-vim
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-15 13:38:09 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-15 13:38:09 +0100
commitdb70871b2044b9bfde346d6f4027dafb0a013c4c (patch)
tree34548aee54e5458d3754bd8c8f987acdb5ee444c /app-vim
parent1c382dc5dbc52576ac2300fee0498af8af44e7b4 (diff)
gentoo auto-resync : 15:06:2023 - 13:38:09
Diffstat (limited to 'app-vim')
-rw-r--r--app-vim/Manifest.gzbin31590 -> 31597 bytes
-rw-r--r--app-vim/gentoo-syntax/Manifest2
-rw-r--r--app-vim/gentoo-syntax/gentoo-syntax-11.ebuild42
3 files changed, 44 insertions, 0 deletions
diff --git a/app-vim/Manifest.gz b/app-vim/Manifest.gz
index d9689086ab0a..81c5f1855b5d 100644
--- a/app-vim/Manifest.gz
+++ b/app-vim/Manifest.gz
Binary files differ
diff --git a/app-vim/gentoo-syntax/Manifest b/app-vim/gentoo-syntax/Manifest
index 466cb62b2ba8..5d8c4f60a254 100644
--- a/app-vim/gentoo-syntax/Manifest
+++ b/app-vim/gentoo-syntax/Manifest
@@ -1,4 +1,6 @@
DIST gentoo-syntax-10.tar.bz2 20945 BLAKE2B 7e081ae2d1498fc0b0616c750881c6f47cbae21d88d876c33d54bae0ff32f5eca44a004e31714fa4af0d351656c72df9e69f33ff0f97e6a2c59d835aacbd44a6 SHA512 790e24ac5427b50f1cd332b895e477bc9715a681cf8c21aaaff722151e6245b45fb33f49465258280eab6a903f3b0c8a8d40b935f44942b6b93f5c0d3c7c420a
+DIST gentoo-syntax-11.tar.bz2 20986 BLAKE2B dd4d4d3a65480a4600d9c1372fdb1db40c07d3a954232513a535cd9e7d59e5e89f185e32aa7bfe38909e1ef4b0e2639136478ba9ab7eb6ceedd9fdb459b08da2 SHA512 9c74b38880429e2e980e8f44b51ed5bc3bb1431d8429a7ac66574556e3ca01e909c445585da9152d78e38d23cc9a4c100bb81f56ea8c0b63291b8df0dca7b886
EBUILD gentoo-syntax-10.ebuild 1200 BLAKE2B bc3c6960d94b3f50e52dcfc8de276c6070745233ec7a1519d2bc01930ef03b7d67efa8335fdba040922bfc48660498f29ca9906f1a96d4d1f58668159692b6b0 SHA512 430dcdf9a519ff4550200f81f588b8367a792eaea86bada841ffd3c9b2dd6ec30c243e8f95b02edc6002f1320531e7f80083e1421dc94c9126f7eeb33b14d4c9
+EBUILD gentoo-syntax-11.ebuild 1208 BLAKE2B 5f6ba36cc2b34fe5bbe101e0b00de2fa2d38b9cd6e66cd12b6b580f7b1ce18e62a08167b549d02bc4c175d9ee523f83bf7a760a94c171370d30a8eedd40ce7c2 SHA512 e965b2e3da9ee8ddd92f0d5d214d60c7b244dc0a0b3de9d9497a558de7a2ddfef39f948079512191754173f073c0824e2086be7900df8d16c160aacb3ee6bf58
EBUILD gentoo-syntax-9999.ebuild 1084 BLAKE2B 5e2edf4d1eddb74486a7ef6c8025a2874591d90d0ff1bb5077781f3c66d43bfbebf0421561a7c730e1baff613776c0962c907aec502a6627d8361034b28e1bf3 SHA512 4af267e60fcf53b736c41232cb44241d2181afd3b38516a6e4a7a7b7ea83db10a4fec7272b362847bf773296f348a2b08503ce757886a14ff08a215ba5341194
MISC metadata.xml 586 BLAKE2B 9425e6a21617f806a0232c7f0ff75f148dc6855679236c9c2b88270db48161d3bffcb32066b372dc6af9cbac594f9d9dce6447d03fc675c151e75982f86ba598 SHA512 cb343dede228edd5c51dc2b2f6b8a1f09e4847365284218d5eb0c23c675f32fe4ab5025c6671f1dafbb63a87b83763a9caf97b04945329c32a1898123149d04b
diff --git a/app-vim/gentoo-syntax/gentoo-syntax-11.ebuild b/app-vim/gentoo-syntax/gentoo-syntax-11.ebuild
new file mode 100644
index 000000000000..8465cb7009c6
--- /dev/null
+++ b/app-vim/gentoo-syntax/gentoo-syntax-11.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: Gentoo and Portage syntax highlighting"
+HOMEPAGE="https://github.com/gentoo/gentoo-syntax"
+SRC_URI="https://gitweb.gentoo.org/proj/gentoo-syntax.git/snapshot/${P}.tar.bz2"
+
+LICENSE="vim"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE="ignore-glep31"
+
+VIM_PLUGIN_HELPFILES="gentoo-syntax"
+VIM_PLUGIN_MESSAGES="filetype"
+
+src_prepare() {
+ default
+ if use ignore-glep31 ; then
+ for f in ftplugin/*.vim ; do
+ ebegin "Removing UTF-8 rules from ${f} ..."
+ sed -i -e 's~\(setlocal fileencoding=utf-8\)~" \1~' ${f} \
+ || die "waah! bad sed voodoo. need more goats."
+ eend $?
+ done
+ fi
+}
+
+pkg_postinst() {
+ vim-plugin_pkg_postinst
+
+ if [[ -z ${REPLACING_VERSIONS} ]] ; then
+ if use ignore-glep31 1>/dev/null ; then
+ ewarn "You have chosen to disable the rules which ensure GLEP 31"
+ ewarn "compliance. When editing ebuilds, please make sure you get"
+ ewarn "the character set correct."
+ fi
+ fi
+}