summaryrefslogtreecommitdiff
path: root/app-vim
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-29 19:13:18 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-29 19:13:18 +0000
commit62090949b4fde34bbcbb4bd770a9635c6ac0c55e (patch)
tree2af5001a82f05c858f1e80e2231929c173a8bb55 /app-vim
parent04a447f4f2679e9687093f49d8a9ea911fac9a9b (diff)
gentoo auto-resync : 29:03:2024 - 19:13:18
Diffstat (limited to 'app-vim')
-rw-r--r--app-vim/Manifest.gzbin31590 -> 31594 bytes
-rw-r--r--app-vim/gentoo-syntax/Manifest2
-rw-r--r--app-vim/gentoo-syntax/gentoo-syntax-14.ebuild42
3 files changed, 44 insertions, 0 deletions
diff --git a/app-vim/Manifest.gz b/app-vim/Manifest.gz
index 32a0f16bc3ac..56d946f9e557 100644
--- a/app-vim/Manifest.gz
+++ b/app-vim/Manifest.gz
Binary files differ
diff --git a/app-vim/gentoo-syntax/Manifest b/app-vim/gentoo-syntax/Manifest
index 6e34113deaed..b123df9745b7 100644
--- a/app-vim/gentoo-syntax/Manifest
+++ b/app-vim/gentoo-syntax/Manifest
@@ -1,4 +1,6 @@
DIST gentoo-syntax-13.tar.bz2 20995 BLAKE2B 90196be7b1f0bbbe8398f327cebe2bbbcffbf8db2e27debc321478911d2413de51ef29d3a94e936e1d92eb4d246237d66d4fa8742fd165e4043ceb2dd80beb9a SHA512 c695dd8c80b551307381a4fb0656adc07321cf60f88e1888ce3a2080343d458a35bb4bda785e233fa4907534b35114c83b5d4b5e3f3bd02d0d6c2dd7ab7deda1
+DIST gentoo-syntax-14.tar.bz2 20988 BLAKE2B 2f11628bec985ef486ad6f04b694df7a2b1e5ef34f5ddb364c7d9dea4a507d9bae4d8de6b00b33358cf651b4fc6816164f22f7760275a1fd0668b89927859cfb SHA512 63914ffb1911d83fa8991a901f9a23ccfc30f0170a6a730cb02919f4adf0ad34c70f4457e006b1c08a004448c6b9e85d97634a8ed8fdf0b4f98ef9fd804eef00
EBUILD gentoo-syntax-13.ebuild 1200 BLAKE2B 9ed0951f9dfc4eb1f37ec1a195c608b2a208d032b92c8dd9c1911250924d0264bee185eff45dddec3681e05c7d2b8e975db57afae506b2d65ccc90cd83d4aba7 SHA512 e5d35275a915fda4a3c4457e5b2f71f0752580d26134dde0b79ba366c95cfc208e1a364a4deeb4733bd08ba5dc2f1806db0ff3f824ac07d693ec99dffd2112ec
+EBUILD gentoo-syntax-14.ebuild 1208 BLAKE2B 66e2a0eb04eda0d4660d5826d00ab95f54ffd5b32d0c227068a3d28e9a651f66c3910c12cf9d3026897c64f02d2f7021b6de0c0c309195c811c9e2b64acdd3e6 SHA512 b44dc2338d8184b9d41cfb616c5de5ab5f9ab40e3d4b242210cecc4b1889bbb55dea1aa0cc91d19ee8881564be7f7dd33ceca0f2f0a71111d59f405ec4d025a2
EBUILD gentoo-syntax-9999.ebuild 1076 BLAKE2B 0688da77100e073b40e8b72bd97a6c3cce176f73a36e89489a5536b73a1cd9896222c967c564aa8cac53c5be61be6e7495b4f460f413d899f23a250108d5eb4a SHA512 ee83565cc9c614275d5bbfc5cc33b19cc8af0d170837358e663a63f8de95d86c37f33995e878355dc482d5381ae9dd77fb891c2d484d5e2307d20d85f053a3b8
MISC metadata.xml 646 BLAKE2B d33ab1ce3b852316a114a27c7768310491f51669a44a183c5b2fe639a0d2e65439759de9a83cb019467ef5d206470454bfe1939906d32c1a7fe6ebad0458e14b SHA512 a75bc08e066deac74dc6a8a9927e232be4facc31e0810121480c07e75549de2cbc974eff9f71f2c59fb17f0739bd0cd9cede9a048af4715047a796b6a5afea7d
diff --git a/app-vim/gentoo-syntax/gentoo-syntax-14.ebuild b/app-vim/gentoo-syntax/gentoo-syntax-14.ebuild
new file mode 100644
index 000000000000..fae057eb2f06
--- /dev/null
+++ b/app-vim/gentoo-syntax/gentoo-syntax-14.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: Gentoo and Portage syntax highlighting"
+HOMEPAGE="https://github.com/gentoo/gentoo-syntax"
+SRC_URI="https://gitweb.gentoo.org/proj/gentoo-syntax.git/snapshot/${P}.tar.bz2"
+
+LICENSE="vim"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE="ignore-glep31"
+
+VIM_PLUGIN_HELPFILES="gentoo-syntax"
+VIM_PLUGIN_MESSAGES="filetype"
+
+src_prepare() {
+ default
+ if use ignore-glep31 ; then
+ for f in ftplugin/*.vim ; do
+ ebegin "Removing UTF-8 rules from ${f} ..."
+ sed -i -e 's~\(setlocal fileencoding=utf-8\)~" \1~' ${f} \
+ || die "waah! bad sed voodoo. need more goats."
+ eend $?
+ done
+ fi
+}
+
+pkg_postinst() {
+ vim-plugin_pkg_postinst
+
+ if [[ -z ${REPLACING_VERSIONS} ]] ; then
+ if use ignore-glep31 1>/dev/null ; then
+ ewarn "You have chosen to disable the rules which ensure GLEP 31"
+ ewarn "compliance. When editing ebuilds, please make sure you get"
+ ewarn "the character set correct."
+ fi
+ fi
+}