summaryrefslogtreecommitdiff
path: root/app-vim
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-31 15:47:53 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-10-31 15:47:53 +0000
commitd950fa39dbe16d164ed0cb8e3036fd5d0d896a4c (patch)
tree04f92d5d1070a7aedb970ce4539dc6d60253c4df /app-vim
parentbd7908c6630f38067350d396ac5d18c3cc2434a0 (diff)
gentoo resync : 31.10.2017
Diffstat (limited to 'app-vim')
-rw-r--r--app-vim/jedi/Manifest3
-rw-r--r--app-vim/jedi/jedi-0.8_p20171015.ebuild33
-rw-r--r--app-vim/jedi/metadata.xml23
3 files changed, 59 insertions, 0 deletions
diff --git a/app-vim/jedi/Manifest b/app-vim/jedi/Manifest
new file mode 100644
index 000000000000..5fb66e8a08ef
--- /dev/null
+++ b/app-vim/jedi/Manifest
@@ -0,0 +1,3 @@
+DIST jedi-0.8_p20171015.zip 43567 SHA256 a120fc6c611f4ee37771d6deb4b871a2d40ca7125231e6f262aa28772eb06880 SHA512 d69fa77ada22b0c75b7ec4ad1765035454312707ffb0f8a0bb0de4928e5fd21b08e39ab28b3f0ff9b37c8eb5389bc44c507fa2a08c0322510a57a91d7de028e6 WHIRLPOOL 150efcb21de8cd8fe523116f67999a99ae28438779eba40a1d8889896000ceebbd1fc9c8a22d0bfacd1619ad36d3ef60df2d97d254075c3a82b2f091e5d93d55
+EBUILD jedi-0.8_p20171015.ebuild 816 SHA256 43173ec80f430d0e0fc2e8ae61a24cde210c523594b3d5911b073dc6eb01b976 SHA512 944f9a0480661eb12af8d7579a73733ec19a94523e93b9ecea4bca9695ae2fa478e9703a3b4aee3ae1b4b7e3568f6e9c1b120025e1df8d04549a915cbdc4f6b9 WHIRLPOOL 5c5bcfd3185b5803a08f11eba9958e898c7db1bc231aa9a774de925aac7008a71f1ba70fa640ae5d00d9ef7d1ff1686b33733edb50f34c5967e4032acacd8711
+MISC metadata.xml 740 SHA256 997b1c138fc3b4f80127767a96cb092426a3ec974ea299b4b4f519acb5b90654 SHA512 145652296b05261952034b26cf36a6fdabee22cdccf4b85914c383e1fde270ca66fcc0b5cae43294907b0730005eb3ce87feb39b716f89740277a9a133229142 WHIRLPOOL 215e73cbc5e5a801e19ec4c32718f8798b6d86d0bd8e7be4353f98ea3281e6d145c06191ebbf68ecedcd1e8c9d569a81c598402a87722caddf2205f8da01e6ec
diff --git a/app-vim/jedi/jedi-0.8_p20171015.ebuild b/app-vim/jedi/jedi-0.8_p20171015.ebuild
new file mode 100644
index 000000000000..f1f7ea7d4586
--- /dev/null
+++ b/app-vim/jedi/jedi-0.8_p20171015.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4} )
+
+inherit vim-plugin python-r1 python-utils-r1
+
+# Commit Date: Sun Oct 15 20:51:54 2017 +0200
+COMMIT="77924398bd594e238766153cec97ace62650f082"
+
+DESCRIPTION="vim plugin: binding to the autocompletion library jedi"
+HOMEPAGE="https://github.com/davidhalter/jedi-vim"
+SRC_URI="https://github.com/davidhalter/jedi-vim/archive/${COMMIT}.zip -> ${P}.zip"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/jedi[${PYTHON_USEDEP}]"
+DEPEND="app-editors/vim[python]"
+
+S="${WORKDIR}/jedi-vim-${COMMIT}"
+
+# Tests are broken.
+RESTRICT="test"
+
+# Makefile tries hard to call tests so let's silence this phase.
+src_compile() { :; }
+
+src_install() {
+ vim-plugin_src_install
+}
diff --git a/app-vim/jedi/metadata.xml b/app-vim/jedi/metadata.xml
new file mode 100644
index 000000000000..e29e8e7eb84b
--- /dev/null
+++ b/app-vim/jedi/metadata.xml
@@ -0,0 +1,23 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>horea.christ@gmail.com</email>
+ <name>Horea Christian</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>vim@gentoo.org</email>
+ <name>Gentoo Vim Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ Jedi-vim is a VIM binding to the autocompletion library Jedi.
+ Apart from that, jedi-vim provides a number of keybindings.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">davidhalter/jedi-vim</remote-id>
+ </upstream>
+</pkgmetadata>