summaryrefslogtreecommitdiff
path: root/app-vim/youcompleteme
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-vim/youcompleteme
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-vim/youcompleteme')
-rw-r--r--app-vim/youcompleteme/Manifest4
-rw-r--r--app-vim/youcompleteme/metadata.xml11
-rw-r--r--app-vim/youcompleteme/youcompleteme-20130910.ebuild85
-rw-r--r--app-vim/youcompleteme/youcompleteme-99999999.ebuild111
4 files changed, 211 insertions, 0 deletions
diff --git a/app-vim/youcompleteme/Manifest b/app-vim/youcompleteme/Manifest
new file mode 100644
index 000000000000..12f660b7f355
--- /dev/null
+++ b/app-vim/youcompleteme/Manifest
@@ -0,0 +1,4 @@
+DIST youcompleteme-20130910.tar.xz 2340104 BLAKE2B 1d50eae1e53d1acc3e9599ade6c5686602cf28997574dcf128b1ed1f812548c51e0c5ad45547ec12fc44d7391ce539c7cd8785ae823978ce18b870dd794f07a2 SHA512 c1022a27ced00e8ba8e9aa25029a0032805331cf0f80342aaaf9d7d4ec7780a098ffbd315068f19f6c98b00c4b4b43e59c7fa40070057e097ca40f6398b53b6b
+EBUILD youcompleteme-20130910.ebuild 1874 BLAKE2B da7bff5e1747bcc76e13f616790c2054b142e9a3854525c5fe9369d9926442e92cdc981de69bada42e200bbfd64a221587140fd08977762f9e8998f6479868fb SHA512 01415a479a88c945f7e97d62afa5dfb86154cef797245da312b65f3b355944f211367ffc8f64a02f440698d4d46b8dae996554c27463ca1f8d39e8d4209de7a1
+EBUILD youcompleteme-99999999.ebuild 2872 BLAKE2B 0671b442ae0b4b1c8379b89dc384c83196d8f683d370a957f6bdd076f40dcdba9175177fcec9733ada197f4479fe722e112c2e29fe3dee6090b8dc82684858ab SHA512 7eafb0cd1a7d2e8bf51ea6e1465b1f0d51ff422e418ca399a970d8baad2f7651b6cadd2c4655f9c4b65088375feb6ec7f431e2c5410536433e46e993a7203039
+MISC metadata.xml 372 BLAKE2B b057ef7819a6a3018c88a692b3f94befe2b3055d3d014790bfdf4de690cdd9e589e12b1d802e5487af104b5cb7d87395e7c0a4130dde622a3a48d7c2f3c507a2 SHA512 3afacd989d495928012e5a1b1c2bb6d14209cbcb1e347a24c1c0881c758642cc8457ee7b6202b8d129e3f08dc21492792715fc5452f8ffc33f719da9a447fdac
diff --git a/app-vim/youcompleteme/metadata.xml b/app-vim/youcompleteme/metadata.xml
new file mode 100644
index 000000000000..1b0669747edd
--- /dev/null
+++ b/app-vim/youcompleteme/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>vim@gentoo.org</email>
+ <name>Gentoo Vim Project</name>
+ </maintainer>
+ <use>
+ <flag name="clang">Enable semantic support for C-family languages using <pkg>sys-devel/clang</pkg></flag>
+ </use>
+</pkgmetadata>
diff --git a/app-vim/youcompleteme/youcompleteme-20130910.ebuild b/app-vim/youcompleteme/youcompleteme-20130910.ebuild
new file mode 100644
index 000000000000..6e36f48e89f6
--- /dev/null
+++ b/app-vim/youcompleteme/youcompleteme-20130910.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils multilib python-single-r1 cmake-utils vim-plugin
+
+if [[ ${PV} == 9999* ]] ; then
+ EGIT_REPO_URI="https://github.com/Valloric/YouCompleteMe.git"
+ inherit git-r3
+else
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="https://dev.gentoo.org/~radhermit/vim/${P}.tar.xz"
+fi
+
+DESCRIPTION="vim plugin: a code-completion engine for Vim"
+HOMEPAGE="https://valloric.github.io/YouCompleteMe/"
+
+LICENSE="GPL-3"
+IUSE="+clang test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ clang? ( >=sys-devel/clang-3.3 )
+ || (
+ app-editors/vim[python,${PYTHON_USEDEP}]
+ app-editors/gvim[python,${PYTHON_USEDEP}]
+ )"
+DEPEND="${RDEPEND}
+ test? (
+ >=dev-python/mock-1.0.1[${PYTHON_USEDEP}]
+ >=dev-python/nose-1.3.0[${PYTHON_USEDEP}]
+ )"
+
+CMAKE_IN_SOURCE_BUILD=1
+CMAKE_USE_DIR=${S}/cpp
+
+VIM_PLUGIN_HELPFILES="${PN}"
+
+src_prepare() {
+ if ! use test ; then
+ sed -i '/^add_subdirectory( tests )/d' cpp/ycm/CMakeLists.txt || die
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_use clang CLANG_COMPLETER)
+ $(cmake-utils_use_use clang SYSTEM_LIBCLANG)
+ )
+ cmake-utils_src_configure
+}
+
+src_test() {
+ # TODO: use system gtest
+ cd "${S}"/cpp || die
+ emake ycm_core_tests
+ cd ycm/tests || die
+ LD_LIBRARY_PATH="${EROOT}"/usr/$(get_libdir)/llvm \
+ "${S}"/cpp/ycm/tests/ycm_core_tests || die
+
+ cd "${S}"/python/ycm || die
+ nosetests --verbose || die
+}
+
+src_install() {
+ dodoc *.md
+ rm -r *.md *.sh COPYING.txt cpp || die
+ find python -name *test* -exec rm -rf {} + || die
+ rm python/libclang.so || die
+
+ vim-plugin_src_install
+
+ python_optimize "${ED}"
+ python_fix_shebang "${ED}"
+}
+
+pkg_postinst() {
+ vim-plugin_pkg_postinst
+
+ [[ -z ${REPLACING_VERSIONS} ]] && \
+ optfeature "better python autocompletion" dev-python/jedi
+}
diff --git a/app-vim/youcompleteme/youcompleteme-99999999.ebuild b/app-vim/youcompleteme/youcompleteme-99999999.ebuild
new file mode 100644
index 000000000000..b41a7b847a87
--- /dev/null
+++ b/app-vim/youcompleteme/youcompleteme-99999999.ebuild
@@ -0,0 +1,111 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils multilib python-single-r1 cmake-utils vim-plugin
+
+if [[ ${PV} == 9999* ]] ; then
+ EGIT_REPO_URI="https://github.com/Valloric/YouCompleteMe.git"
+ inherit git-r3
+else
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="https://dev.gentoo.org/~radhermit/vim/${P}.tar.xz"
+fi
+
+DESCRIPTION="vim plugin: a code-completion engine for Vim"
+HOMEPAGE="https://valloric.github.io/YouCompleteMe/"
+
+LICENSE="GPL-3"
+IUSE="+clang test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+COMMON_DEPEND="
+ ${PYTHON_DEPS}
+ clang? ( >=sys-devel/clang-3.3 )
+ dev-libs/boost[python,threads,${PYTHON_USEDEP}]
+ || (
+ app-editors/vim[python,${PYTHON_USEDEP}]
+ app-editors/gvim[python,${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="
+ ${COMMON_DEPEND}
+ dev-python/bottle[${PYTHON_USEDEP}]
+ virtual/python-futures[${PYTHON_USEDEP}]
+ dev-python/jedi[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/sh[${PYTHON_USEDEP}]
+ dev-python/waitress[${PYTHON_USEDEP}]
+"
+DEPEND="
+ ${COMMON_DEPEND}
+ test? (
+ >=dev-python/mock-1.0.1[${PYTHON_USEDEP}]
+ >=dev-python/nose-1.3.0[${PYTHON_USEDEP}]
+ >=dev-cpp/gtest-1.8.0
+ )
+"
+
+CMAKE_IN_SOURCE_BUILD=1
+CMAKE_USE_DIR=${S}/third_party/ycmd/cpp
+
+VIM_PLUGIN_HELPFILES="${PN}"
+
+src_prepare() {
+ if ! use test; then
+ sed -i '/^add_subdirectory( tests )/d' third_party/ycmd/cpp/ycm/CMakeLists.txt || die
+ fi
+
+ for third_party_module in requests pythonfutures; do
+ if [[ -d "${third_party_module}" ]]; then
+ rm -r "${S}"/third_party/${third_party_module} || die "Failed to remove third party module ${third_party_module}"
+ fi
+ done
+
+ # Argparse is included in python 2.7
+ for third_party_module in argparse bottle jedi waitress sh requests; do
+ if [[ -d "${third_party_module}" ]]; then
+ rm -r "${S}"/third_party/ycmd/third_party/${third_party_module} || die "Failed to remove third party module ${third_party_module}"
+ fi
+ done
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_use clang CLANG_COMPLETER)
+ $(cmake-utils_use_use clang SYSTEM_LIBCLANG)
+ -DUSE_SYSTEM_BOOST=ON
+ -DUSE_SYSTEM_GMOCK=ON
+ )
+ cmake-utils_src_configure
+}
+
+src_test() {
+ cd "${S}/third_party/ycmd/cpp/ycm/tests" || die
+ LD_LIBRARY_PATH="${EROOT}"/usr/$(get_libdir)/llvm \
+ ./ycm_core_tests || die
+
+ cd "${S}"/python/ycm || die
+
+ local dirs=( "${S}"/third_party/*/ "${S}"/third_party/ycmd/third_party/*/ )
+ local -x PYTHONPATH=${PYTHONPATH}:$(IFS=:; echo "${dirs[*]}")
+
+ nosetests --verbose || die
+}
+
+src_install() {
+ dodoc *.md third_party/ycmd/*.md
+ rm -r *.md *.sh COPYING.txt third_party/ycmd/cpp || die
+ rm -r third_party/ycmd/{*.md,*.sh} || die
+ find python -name *test* -exec rm -rf {} + || die
+ egit_clean
+ rm third_party/ycmd/libclang.so* || die
+
+ vim-plugin_src_install
+
+ python_optimize "${ED}"
+ python_fix_shebang "${ED}"
+}