summaryrefslogtreecommitdiff
path: root/app-vim/vimpress/vimpress-3.2.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-vim/vimpress/vimpress-3.2.0.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-vim/vimpress/vimpress-3.2.0.ebuild')
-rw-r--r--app-vim/vimpress/vimpress-3.2.0.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/app-vim/vimpress/vimpress-3.2.0.ebuild b/app-vim/vimpress/vimpress-3.2.0.ebuild
new file mode 100644
index 000000000000..800fe671ea65
--- /dev/null
+++ b/app-vim/vimpress/vimpress-3.2.0.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-single-r1 vim-plugin
+
+DESCRIPTION="vim plugin: manage wordpress blogs from vim"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=3510"
+LICENSE="vim"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="|| ( app-editors/vim[python,${PYTHON_USEDEP}] app-editors/gvim[python,${PYTHON_USEDEP}] )
+ ${PYTHON_DEPS}
+ dev-python/markdown[${PYTHON_USEDEP}]"
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"