summaryrefslogtreecommitdiff
path: root/app-vim/vimcalc
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-vim/vimcalc
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-vim/vimcalc')
-rw-r--r--app-vim/vimcalc/Manifest3
-rw-r--r--app-vim/vimcalc/metadata.xml8
-rw-r--r--app-vim/vimcalc/vimcalc-1.3-r2.ebuild43
3 files changed, 54 insertions, 0 deletions
diff --git a/app-vim/vimcalc/Manifest b/app-vim/vimcalc/Manifest
new file mode 100644
index 000000000000..2f85d5e40c09
--- /dev/null
+++ b/app-vim/vimcalc/Manifest
@@ -0,0 +1,3 @@
+DIST vimcalc-1.3.zip 24993 BLAKE2B 8cfd0a399b4888fa4e9244f7f6a315f97a3e74c78879c281d596a1a5c109711933b66b44493a2ee3c136e1159d937c95707b06c54a5342457494a3c945dcf66f SHA512 1b377f284a7b68d200b08bdacee2080a60412e6ba1fd530eb0075dbc84fba30b37cec45e60d916aa80d057809b79f4d816f3a85f903d0e2fc7d06240dcdbb600
+EBUILD vimcalc-1.3-r2.ebuild 963 BLAKE2B 53db13c995c4e07119bd6da43967f657f24c86e487aa2b1b897656bf5cdea224db211ea501e375e98d1f2b28e8f80318b4e2a0930ea02eabe93ba084f573f2e2 SHA512 0df90e193f0fb553ce840ae499821fdd83d135787e64124d4bc767e4fdeee5dbb29ea180bd0507ce80a38ba50aaab156349f8fac49542ef9eb631d4f39fe4ba9
+MISC metadata.xml 249 BLAKE2B 7ae6eac3ca23edbcbaa6aee682bb4aec155e3166f169eef8e4400e59fa56113ecc3593680d55cc57f08a4a718963dd3d0bb804bd1e8771ed60a4bebaae9db281 SHA512 4051dd059d975d2e1799125f7defbf5a62a168241d8b83d83710592efd60808800951c4fd6da1294044d7e7ec6b757b8d50593fd076696f826dec761e99645c7
diff --git a/app-vim/vimcalc/metadata.xml b/app-vim/vimcalc/metadata.xml
new file mode 100644
index 000000000000..5c000c763084
--- /dev/null
+++ b/app-vim/vimcalc/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>vim@gentoo.org</email>
+ <name>Gentoo Vim Project</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/app-vim/vimcalc/vimcalc-1.3-r2.ebuild b/app-vim/vimcalc/vimcalc-1.3-r2.ebuild
new file mode 100644
index 000000000000..151fa8451f7a
--- /dev/null
+++ b/app-vim/vimcalc/vimcalc-1.3-r2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-single-r1 vim-plugin
+
+DESCRIPTION="vim plugin: provides an interactive calculator inside vim"
+HOMEPAGE="https://www.vim.org/scripts/script.php?script_id=3329"
+SRC_URI="https://www.vim.org/scripts/download_script.php?src_id=15317 -> ${P}.zip"
+LICENSE="vim"
+KEYWORDS="amd64 x86"
+
+VIM_PLUGIN_HELPFILES="vimcalc"
+
+DEPEND="
+ app-arch/unzip
+ ${PYTHON_DEPS}"
+
+RDEPEND="
+ || ( app-editors/vim[python,${PYTHON_USEDEP}] app-editors/gvim[python,${PYTHON_USEDEP}] )
+ ${PYTHON_DEPS}"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+S="${WORKDIR}/${PN}-v${PV}"
+
+src_prepare() {
+ # Remove .DS_Store files that should not be installed
+ find -type f -name '.DS*' -delete || die
+}
+
+src_test() {
+ cd plugin || die
+ "${PYTHON}" tests.py || die "Tests failed"
+}
+
+src_install() {
+ rm plugin/tests.py || die
+ vim-plugin_src_install
+}