summaryrefslogtreecommitdiff
path: root/app-vim/vim-go
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-vim/vim-go
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-vim/vim-go')
-rw-r--r--app-vim/vim-go/Manifest3
-rw-r--r--app-vim/vim-go/metadata.xml11
-rw-r--r--app-vim/vim-go/vim-go-1.13.ebuild22
3 files changed, 36 insertions, 0 deletions
diff --git a/app-vim/vim-go/Manifest b/app-vim/vim-go/Manifest
new file mode 100644
index 000000000000..d24ed6b18398
--- /dev/null
+++ b/app-vim/vim-go/Manifest
@@ -0,0 +1,3 @@
+DIST vim-go-1.13.tar.gz 870173 BLAKE2B a2f67cef249191cf91caf45c120e471301a89ee365ba9add839edea17990ff3aba7238965dac1c71a89d2004dfcfd486319fc4f1474c7ee94d3845724cd9b289 SHA512 c2aa31104168f3a8e1f96b0ad2c51dc1c2e5a1de3db76f0009edfb38bf60ebfcd9bd8a86fedb6ff6d6d789973a557d6ed03e38e67159bc43c5231449b0253c25
+EBUILD vim-go-1.13.ebuild 585 BLAKE2B a46b8e468163abddf2ec305b76e24fe82ab82f631dbf773bf927c0962f55303b21e2eeba36e44a0c2d172160c65fa6ec02cde729260783b0ae9c7a5e0f199fe5 SHA512 4d7b8ba229f5c1318993517923701078909ac0fda31c34ea296b62e5e16395a7bb926ea9811b6fbfc8df4e660435bdc1407da209dc4dbb56cb7f887854e31e73
+MISC metadata.xml 326 BLAKE2B 2c1d1ecf6dc417d2646fbeeebbd2bf1191c93f6439df663e863cebe0b33cfea5040bbe3f1b85107f5370395d9472c4f903379c3a5cf925a997789c492ac0cc66 SHA512 0075500c50b5ad7cf5610fbc4bb71e3ee3d655bc089916371ee0d66731387a2268df98ed6d7fcad6e70db28d6852b48c2e6742e131b7c5d50fc7a9656807fc60
diff --git a/app-vim/vim-go/metadata.xml b/app-vim/vim-go/metadata.xml
new file mode 100644
index 000000000000..a34620b83509
--- /dev/null
+++ b/app-vim/vim-go/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>vim@gentoo.org</email>
+ <name>Gentoo Vim Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">fatih/vim-go</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-vim/vim-go/vim-go-1.13.ebuild b/app-vim/vim-go/vim-go-1.13.ebuild
new file mode 100644
index 000000000000..39d68cf0d91e
--- /dev/null
+++ b/app-vim/vim-go/vim-go-1.13.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: Go development plugin for Vim"
+HOMEPAGE="https://github.com/fatih/vim-go"
+SRC_URI="https://github.com/fatih/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="BSD"
+KEYWORDS="amd64 x86"
+
+VIM_PLUGIN_HELPFILES="$PN"
+
+RESTRICT="test"
+
+src_compile() {
+ # safely skip `make test` triggered by `make` as it runs `go get` commands
+ # TODO: see :GoInstallBinaries (https://github.com/fatih/vim-go/blob/master/doc/vim-go.txt)
+ :;
+}