summaryrefslogtreecommitdiff
path: root/app-vim/vim-go/vim-go-1.20.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-06-02 21:45:28 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-06-02 21:45:28 +0100
commit2018227e9344edb9da15fc6a4a8298086cc2aa77 (patch)
treec18e1c09e605e94e2a1e93345ad25746cc9e14b9 /app-vim/vim-go/vim-go-1.20.ebuild
parent6f8038813c460b4f0572d5ef595cdfa94af3a94d (diff)
gentoo resync : 02.06.2019
Diffstat (limited to 'app-vim/vim-go/vim-go-1.20.ebuild')
-rw-r--r--app-vim/vim-go/vim-go-1.20.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/app-vim/vim-go/vim-go-1.20.ebuild b/app-vim/vim-go/vim-go-1.20.ebuild
new file mode 100644
index 000000000000..3a6740617589
--- /dev/null
+++ b/app-vim/vim-go/vim-go-1.20.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: Go development plugin for Vim"
+HOMEPAGE="https://github.com/fatih/vim-go"
+SRC_URI="https://github.com/fatih/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86"
+
+VIM_PLUGIN_HELPFILES="${PN}"
+
+RESTRICT="test"
+
+src_compile() {
+ # safely skip `make test` triggered by `make` as it runs `go get` commands
+ # TODO: see :GoInstallBinaries (https://github.com/fatih/vim-go/blob/master/doc/vim-go.txt)
+ :;
+}