summaryrefslogtreecommitdiff
path: root/app-vim/tcomment
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-vim/tcomment
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-vim/tcomment')
-rw-r--r--app-vim/tcomment/Manifest4
-rw-r--r--app-vim/tcomment/metadata.xml11
-rw-r--r--app-vim/tcomment/tcomment-3.08.1.ebuild28
-rw-r--r--app-vim/tcomment/tcomment-9999.ebuild28
4 files changed, 71 insertions, 0 deletions
diff --git a/app-vim/tcomment/Manifest b/app-vim/tcomment/Manifest
new file mode 100644
index 000000000000..c1febf9388cb
--- /dev/null
+++ b/app-vim/tcomment/Manifest
@@ -0,0 +1,4 @@
+DIST tcomment-3.08.1.tar.gz 49918 BLAKE2B df63a01432101e018a39f7b54dec0b91b415263e2b6c0f3e63521e1abe2247a005a1fc900cd6d18cfd908f75ae4b5767a5f7dc21ae620985d3465676c456a389 SHA512 609d5eb1e7785fb1af829000ab27ab63ac2bb7550bcd0f91c7c35f0a8c4b879e5348745f57b11d1e24d37920056ca55da8863e15e40d6fe289617d5d898a4177
+EBUILD tcomment-3.08.1.ebuild 707 BLAKE2B 2ca1a8f759cd34b3e06c66fc605b6a51fffb078fe62b7988d36de10fb625de3ba73723d89c5121355a1299a9a2fb6f57d55b59cdbe1f889545f27f4619260ff1 SHA512 c93726d4f1769f8b802fddefe6b3150ee6d8e9a6ea239e558f4c19896ec76ee94943c3dcacaf1a9a668cc905a17f0014d0058f7f1147f16aaeac731e645056e7
+EBUILD tcomment-9999.ebuild 709 BLAKE2B 41d87b0f5a50a279b6e7e91143b19a86be3fa9042dcd6959197221b1247523fe06c100f6bebf8e222c443d460590a51966c568e8b9b321fd5671c867d4db0d7e SHA512 ff91f4eb1cfcccc3628bc574014fbcd3fb569cbb45c92777fae3f1a9ec7c5002883f6b569912e0c3773db379825b88c501ede4fe08ce32ff36d8f504a60870e7
+MISC metadata.xml 343 BLAKE2B ad814cdda87bdad08597d6bce76f080143b2ed26239dc162b9d79b11476c6b9cce49b1ec362136569f952673442482399ea7a0a44d392497417a665a378faec7 SHA512 f8b176729889aea616f7ca8e3f0de17519debc53a102e4db499aa2e6a196482a5bc47b235fcaa88249c748ea7a583b2d0b31a5498571fdf3fa7520882e8c6257
diff --git a/app-vim/tcomment/metadata.xml b/app-vim/tcomment/metadata.xml
new file mode 100644
index 000000000000..9e97359a2544
--- /dev/null
+++ b/app-vim/tcomment/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>vim@gentoo.org</email>
+ <name>Gentoo Vim Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">tomtom/tcomment_vim</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-vim/tcomment/tcomment-3.08.1.ebuild b/app-vim/tcomment/tcomment-3.08.1.ebuild
new file mode 100644
index 000000000000..2e4d330ed1d7
--- /dev/null
+++ b/app-vim/tcomment/tcomment-3.08.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit vim-plugin
+
+MY_PN="tcomment_vim"
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/tomtom/nerdtree.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/tomtom/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="amd64 x86"
+ S="${WORKDIR}/${MY_PN}-${PV}"
+fi
+
+DESCRIPTION="vim plugin: an extensible and universal comment toggler"
+HOMEPAGE="https://www.vim.org/scripts/script.php?script_id=1173 https://github.com/tomtom/tcomment_vim"
+LICENSE="GPL-3"
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+src_prepare() {
+ default
+ rm -r README LICENSE.TXT etc spec addon* || die
+}
diff --git a/app-vim/tcomment/tcomment-9999.ebuild b/app-vim/tcomment/tcomment-9999.ebuild
new file mode 100644
index 000000000000..4b803fc97fe3
--- /dev/null
+++ b/app-vim/tcomment/tcomment-9999.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit vim-plugin
+
+MY_PN="tcomment_vim"
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/tomtom/nerdtree.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/tomtom/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/${MY_PN}-${PV}"
+fi
+
+DESCRIPTION="vim plugin: an extensible and universal comment toggler"
+HOMEPAGE="https://www.vim.org/scripts/script.php?script_id=1173 https://github.com/tomtom/tcomment_vim"
+LICENSE="GPL-3"
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+src_prepare() {
+ default
+ rm -r README LICENSE.TXT etc spec addon* || die
+}