summaryrefslogtreecommitdiff
path: root/app-vim/tcomment/tcomment-4.00.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-15 04:49:10 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-15 04:49:10 +0100
commitefca79f216bfeffd55e7731fbf24126d093e1084 (patch)
treef19ba31d8686b3de4192db3e4c4dc9f3d9af54b5 /app-vim/tcomment/tcomment-4.00.ebuild
parentea7f3f690b55cdfa8b2d350b03c1dfc0c8357a51 (diff)
gentoo auto-resync : 15:09:2023 - 04:49:10
Diffstat (limited to 'app-vim/tcomment/tcomment-4.00.ebuild')
-rw-r--r--app-vim/tcomment/tcomment-4.00.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/app-vim/tcomment/tcomment-4.00.ebuild b/app-vim/tcomment/tcomment-4.00.ebuild
new file mode 100644
index 000000000000..be5dacfaeb75
--- /dev/null
+++ b/app-vim/tcomment/tcomment-4.00.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit vim-plugin
+
+MY_PN="tcomment_vim"
+
+DESCRIPTION="vim plugin: an extensible and universal comment toggler"
+HOMEPAGE="https://www.vim.org/scripts/script.php?script_id=1173
+ https://github.com/tomtom/tcomment_vim"
+SRC_URI="https://github.com/tomtom/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="GPL-3"
+KEYWORDS="~amd64 ~x86"
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+DOCS=( CHANGES.TXT README )
+
+src_prepare() {
+ default
+ rm -r etc spec addon* || die
+}