summaryrefslogtreecommitdiff
path: root/app-vim/taglist
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-vim/taglist
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-vim/taglist')
-rw-r--r--app-vim/taglist/Manifest4
-rw-r--r--app-vim/taglist/files/taglist-3.4-ebuilds.patch12
-rw-r--r--app-vim/taglist/metadata.xml11
-rw-r--r--app-vim/taglist/taglist-4.6.ebuild19
4 files changed, 46 insertions, 0 deletions
diff --git a/app-vim/taglist/Manifest b/app-vim/taglist/Manifest
new file mode 100644
index 000000000000..833d321e452f
--- /dev/null
+++ b/app-vim/taglist/Manifest
@@ -0,0 +1,4 @@
+AUX taglist-3.4-ebuilds.patch 451 BLAKE2B 4d22d3ceaa1af58b804710cd1af60b402c6295a269d51fd39bb78911e3a44f0a775c52676ca6d939a9c9c8a99ecdd17996b3c3ad0b4c9bade0866ccedd742eec SHA512 9fbff7c21e0c3bc73738dbb28ce8a10bf9f5b052d669468940f471988e8e15862b75104db1b0cdd209a679c4d72f58b3c147f5fdaaf8248e5ed0bc18f3615684
+DIST taglist-4.6.tar.bz2 40344 BLAKE2B e6377f8ac353f77ee7656b95eae0d79722f66ade3f575de14194aa7c2ced7e30d2d3e62ba3873db8b0b3e2985d360f3b4f100072d0bb26617941d3d632ab5cc4 SHA512 64686f2685cf4f9b09eeb7e1981a1b9d514cce2f6ea4bdf3e3613037d9818556ad6ed95740a84b4d73eba3fa1d5d58a41f15e1bc0a1403c50a810f5a704f3073
+EBUILD taglist-4.6.ebuild 501 BLAKE2B e9ad234475fe6f897d1f5b94ec0896a98c1dcf63f4f17360809260766cdaa096f1f9818cf95982695347111e62167f54a7e1f0fe058a2a93bd0a45d8075e47dd SHA512 a292c887ebda9ff2372c54c5755926f3d6a710f2931218ec2d301a5fa8b67ad5625a3f89aaaa1aeb7f759e96bafaa734ce8556d1c7f0d448f22588ce29959218
+MISC metadata.xml 330 BLAKE2B 4c578f7ca8885b73f0a298749a5f1335815b25ea619b65200d8d5acf9a6b27502fe00a13b0ab0bd6684c604f87099f0740857054d9e6e62865dc800fa09a4e1a SHA512 0965202e6286e18810375b491ed126f12a309958cb726c259c549c38b1813468e0d17a1d00d01dab882f5ea069cb03aa5c1d4ce09399fb2efefadfe70aaf5dde
diff --git a/app-vim/taglist/files/taglist-3.4-ebuilds.patch b/app-vim/taglist/files/taglist-3.4-ebuilds.patch
new file mode 100644
index 000000000000..8fcc928d4497
--- /dev/null
+++ b/app-vim/taglist/files/taglist-3.4-ebuilds.patch
@@ -0,0 +1,12 @@
+--- taglist-3.4/plugin/taglist.vim.orig 2004-10-02 00:12:58.400215576 +0100
++++ taglist-3.4/plugin/taglist.vim 2004-10-02 00:26:28.535056360 +0100
+@@ -205,6 +205,9 @@
+ let s:tlist_def_cobol_settings = 'cobol;d:data;f:file;g:group;p:paragraph;' .
+ \ 'P:program;s:section'
+
++" ebuilds
++let s:tlist_def_ebuild_settings = 'sh;f:function'
++
+ " eiffel language
+ let s:tlist_def_eiffel_settings = 'eiffel;c:class;f:feature'
+
diff --git a/app-vim/taglist/metadata.xml b/app-vim/taglist/metadata.xml
new file mode 100644
index 000000000000..8b75cc7efb06
--- /dev/null
+++ b/app-vim/taglist/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>vim@gentoo.org</email>
+ <name>Gentoo Vim Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">vim-taglist</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-vim/taglist/taglist-4.6.ebuild b/app-vim/taglist/taglist-4.6.ebuild
new file mode 100644
index 000000000000..b4214d29c76e
--- /dev/null
+++ b/app-vim/taglist/taglist-4.6.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit vim-plugin eutils
+
+DESCRIPTION="vim plugin: ctags-based source code browser"
+HOMEPAGE="http://vim-taglist.sourceforge.net/"
+LICENSE="vim"
+KEYWORDS="alpha amd64 hppa ia64 ~mips ppc sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris"
+
+RDEPEND="dev-util/ctags"
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-3.4-ebuilds.patch
+}