summaryrefslogtreecommitdiff
path: root/app-vim/securemodelines
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-vim/securemodelines
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-vim/securemodelines')
-rw-r--r--app-vim/securemodelines/Manifest3
-rw-r--r--app-vim/securemodelines/metadata.xml17
-rw-r--r--app-vim/securemodelines/securemodelines-20140926.ebuild13
3 files changed, 33 insertions, 0 deletions
diff --git a/app-vim/securemodelines/Manifest b/app-vim/securemodelines/Manifest
new file mode 100644
index 000000000000..cbc834309e92
--- /dev/null
+++ b/app-vim/securemodelines/Manifest
@@ -0,0 +1,3 @@
+DIST securemodelines-20140926.tar.bz2 1562 BLAKE2B 14b58973e25eb91970f62733840a8db20680cc57266e68129d6a490fac970951044a350d936e497797892bf428de737226c9c57c986de5816c0e771bc65418e0 SHA512 15a948781751998d832f445e7c3ad936e5c034fcc9936d977c5cf05215dd541a235fc066f7e774b151fac2afb2b0a59665d13f6f981cc59d4e1135f06f6cdc35
+EBUILD securemodelines-20140926.ebuild 515 BLAKE2B 87bf25ee67f4c45771d8ad0b29fca69e2920c2973cf411600fdc565d7d5d10431186ee99a69e1bffbc0f00e0eb5b6a7328f704b42a75b5de9b84ddb8de4761a5 SHA512 de5054e7363f275d53ae8cfb407a938d7bb30b5b6c9bd9263a7fee1e798d46cea69e5ed988d1fd3ad7b6e580ba2383dfcd4bd916ca3dd98a3dcab2b6a5f179a1
+MISC metadata.xml 621 BLAKE2B 1917398769758c657f0975c986e7ee09056ad2a87782a47523bcc558a2ac1644da90c8310add6e86b29c697264ef817f2bb6f08738cb9df3668a9ed13d416bb2 SHA512 ca9e3cce0633bacbb643201bc746e9c6397e9803c6b6c717c1a6e8fd2582e85e61f9fe7c8ea3ea575de6150ded96a0d26ce0fb6ac973884c37c19ce28ded9204
diff --git a/app-vim/securemodelines/metadata.xml b/app-vim/securemodelines/metadata.xml
new file mode 100644
index 000000000000..419ac8208807
--- /dev/null
+++ b/app-vim/securemodelines/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>vim@gentoo.org</email>
+ <name>Gentoo Vim Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ Vim's internal modeline support allows all sorts of annoying and
+ potentially insecure options to be set. This script implements a much
+ more heavily restricted modeline parser that permits only user-specified
+ options to be set.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">ciaranm/securemodelines</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-vim/securemodelines/securemodelines-20140926.ebuild b/app-vim/securemodelines/securemodelines-20140926.ebuild
new file mode 100644
index 000000000000..1027ea74755f
--- /dev/null
+++ b/app-vim/securemodelines/securemodelines-20140926.ebuild
@@ -0,0 +1,13 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: secure, user-configurable modeline support"
+HOMEPAGE="https://www.vim.org/scripts/script.php?script_id=1876 https://github.com/ciaranm/securemodelines"
+LICENSE="vim"
+KEYWORDS="alpha amd64 hppa ia64 ~mips ppc ppc64 sparc x86 ~x86-fbsd"
+
+VIM_PLUGIN_HELPTEXT="Make sure that you disable vim's builtin modeline support if you have
+enabled it in your .vimrc."