summaryrefslogtreecommitdiff
path: root/app-vim/puppet-syntax
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-vim/puppet-syntax
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-vim/puppet-syntax')
-rw-r--r--app-vim/puppet-syntax/Manifest3
-rw-r--r--app-vim/puppet-syntax/metadata.xml12
-rw-r--r--app-vim/puppet-syntax/puppet-syntax-3.0.1.ebuild19
3 files changed, 34 insertions, 0 deletions
diff --git a/app-vim/puppet-syntax/Manifest b/app-vim/puppet-syntax/Manifest
new file mode 100644
index 000000000000..a97e88622407
--- /dev/null
+++ b/app-vim/puppet-syntax/Manifest
@@ -0,0 +1,3 @@
+DIST puppet-syntax-3.0.1.tar.gz 3548 BLAKE2B b053234203b45cf1748cc72e329c35322dfa48a4d7b39261301398a8d1026035e929a7afe3fa80d59ef67472ebfc317442250e0aa0292047ab38eda9860600b9 SHA512 fb96360e784da578d2ab77a021befe874644cf964c1ca2d8b34b316296872a67679606ad0dfd4ab90027b7d259900af20d831d5e3359d76649e0c6f43546938b
+EBUILD puppet-syntax-3.0.1.ebuild 558 BLAKE2B d357be2e9bde63c42ad22a24a4da64ef4816bc5ac65ce0f8136e4bc132266b5b07d43edb28618c530469ad25e8fe7759866629d4a06aaa0915addf517320190c SHA512 4fe127ba436c49e32ac7379127984c527e7ba3ed8a44d0f2888373938dd4b721e313174c442e7a5d07d5c7da1ca0d85169895fd0f248ffbd4d75b6b22c640cc0
+MISC metadata.xml 363 BLAKE2B de2b732638a0b8b0430ac0aaf25635fdbf86493507d787280c14b8c0da5713d31490d7ff89f4cf1347b7952021336d97f355a45f11653ac027722e977ced20d9 SHA512 cf7d45285491a9c11a9bff7354c6bd726eb0e359114a447321642056d199f117921b3bd15d9a427c5b7af2371c0e10ecffa634cf824df2b59997aca9ce6ff3e6
diff --git a/app-vim/puppet-syntax/metadata.xml b/app-vim/puppet-syntax/metadata.xml
new file mode 100644
index 000000000000..f1f6747112d6
--- /dev/null
+++ b/app-vim/puppet-syntax/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>sysadmin@gentoo.org</email>
+ <name>Gentoo Sysadmin Project</name>
+</maintainer>
+<maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+</maintainer>
+</pkgmetadata>
diff --git a/app-vim/puppet-syntax/puppet-syntax-3.0.1.ebuild b/app-vim/puppet-syntax/puppet-syntax-3.0.1.ebuild
new file mode 100644
index 000000000000..17c83d9b6be0
--- /dev/null
+++ b/app-vim/puppet-syntax/puppet-syntax-3.0.1.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: Puppet configuration files syntax"
+HOMEPAGE="http://puppetlabs.com/"
+SRC_URI="https://dev.gentoo.org/~tampakrap/tarballs/${P}.tar.gz"
+LICENSE="Apache-2.0 GPL-2"
+KEYWORDS="amd64 ~arm hppa ppc ~ppc64 sparc x86 ~amd64-linux ~x64-macos ~x64-solaris"
+
+VIM_PLUGIN_HELPTEXT=\
+"This plugin provides syntax highlighting for Puppet configuration
+files."
+
+DEPEND="!<app-admin/puppet-3.0.1"
+RDEPEND=${DEPEND}