summaryrefslogtreecommitdiff
path: root/app-vim/project
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-vim/project
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-vim/project')
-rw-r--r--app-vim/project/Manifest3
-rw-r--r--app-vim/project/metadata.xml8
-rw-r--r--app-vim/project/project-1.4.1.ebuild17
3 files changed, 28 insertions, 0 deletions
diff --git a/app-vim/project/Manifest b/app-vim/project/Manifest
new file mode 100644
index 000000000000..a7cb0b11a964
--- /dev/null
+++ b/app-vim/project/Manifest
@@ -0,0 +1,3 @@
+DIST project-1.4.1.tar.gz 20705 BLAKE2B 34dcbb500ab83cb0f80c0f7b0a5a17d3e17b04847453041e09cdbb508524e61da2ef75dc5c21ebe448d8c6d9057f1dd6c324753191d54c5f7169b647ee3a9f6c SHA512 315d76a375dda2ba6e5523b80e83b6e53590a31713eb8da4ee976e0698a35eb0419ce88bb2eb3b1793e272a9f23ada1b29c7e8f1460cb36f5b57204cbbb54852
+EBUILD project-1.4.1.ebuild 462 BLAKE2B 229e5e0c854c525a4537e69fa8cce7ff9d2a03df5473bc4013b27ced4d0d27564874f7bd9d044c86a04d8b123946f9fadbc7c06275d4a7b031e5c1846296a975 SHA512 1e58c47eceae807b014b862809768c21ec18206a73f43c01323cb3973f3cfcce1d578674f482cbe1f4ed1ddeff127b6153245a2ec75fbdde3d006858dadfb9ee
+MISC metadata.xml 249 BLAKE2B 7ae6eac3ca23edbcbaa6aee682bb4aec155e3166f169eef8e4400e59fa56113ecc3593680d55cc57f08a4a718963dd3d0bb804bd1e8771ed60a4bebaae9db281 SHA512 4051dd059d975d2e1799125f7defbf5a62a168241d8b83d83710592efd60808800951c4fd6da1294044d7e7ec6b757b8d50593fd076696f826dec761e99645c7
diff --git a/app-vim/project/metadata.xml b/app-vim/project/metadata.xml
new file mode 100644
index 000000000000..5c000c763084
--- /dev/null
+++ b/app-vim/project/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>vim@gentoo.org</email>
+ <name>Gentoo Vim Project</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/app-vim/project/project-1.4.1.ebuild b/app-vim/project/project-1.4.1.ebuild
new file mode 100644
index 000000000000..b90a25189c63
--- /dev/null
+++ b/app-vim/project/project-1.4.1.ebuild
@@ -0,0 +1,17 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: Managing multiple projects with multiple sources like an IDE"
+HOMEPAGE="https://www.vim.org/scripts/script.php?script_id=69"
+SRC_URI="https://www.vim.org/scripts/download_script.php?src_id=6273 -> ${P}.tar.gz"
+
+LICENSE="vim.org"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+S=${WORKDIR}
+
+VIM_PLUGIN_HELPFILES="${PN}"