summaryrefslogtreecommitdiff
path: root/app-vim/gitv/gitv-1.3.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-vim/gitv/gitv-1.3.1.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-vim/gitv/gitv-1.3.1.ebuild')
-rw-r--r--app-vim/gitv/gitv-1.3.1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-vim/gitv/gitv-1.3.1.ebuild b/app-vim/gitv/gitv-1.3.1.ebuild
new file mode 100644
index 000000000000..0c83e952b99e
--- /dev/null
+++ b/app-vim/gitv/gitv-1.3.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit vim-plugin
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/gregsexton/gitv.git"
+else
+ SRC_URI="https://github.com/gregsexton/gitv/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="amd64 x86 ~ppc-macos"
+fi
+
+DESCRIPTION="vim plugin: gitk for vim"
+HOMEPAGE="https://www.vim.org/scripts/script.php?script_id=3574 https://github.com/gregsexton/gitv/"
+LICENSE="vim"
+
+VIM_PLUGIN_HELPFILES="gitv"
+
+RDEPEND="
+ dev-vcs/git
+ app-vim/fugitive"
+
+src_prepare() {
+ rm -f doc/tags addon-info.json roadmap.md || die
+ rm -r img || die
+ default
+}