summaryrefslogtreecommitdiff
path: root/app-vim/gentoo-syntax/gentoo-syntax-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /app-vim/gentoo-syntax/gentoo-syntax-9999.ebuild
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'app-vim/gentoo-syntax/gentoo-syntax-9999.ebuild')
-rw-r--r--app-vim/gentoo-syntax/gentoo-syntax-9999.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/app-vim/gentoo-syntax/gentoo-syntax-9999.ebuild b/app-vim/gentoo-syntax/gentoo-syntax-9999.ebuild
new file mode 100644
index 000000000000..a5cb9329196a
--- /dev/null
+++ b/app-vim/gentoo-syntax/gentoo-syntax-9999.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit git-r3 vim-plugin
+
+DESCRIPTION="vim plugin: Gentoo and Portage syntax highlighting"
+HOMEPAGE="https://github.com/gentoo/gentoo-syntax"
+EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/gentoo-syntax.git
+ https://github.com/gentoo/gentoo-syntax.git"
+
+LICENSE="vim"
+SLOT="0"
+KEYWORDS=""
+IUSE="ignore-glep31"
+
+VIM_PLUGIN_HELPFILES="gentoo-syntax"
+VIM_PLUGIN_MESSAGES="filetype"
+
+src_prepare() {
+ default
+ if use ignore-glep31 ; then
+ for f in ftplugin/*.vim ; do
+ ebegin "Removing UTF-8 rules from ${f} ..."
+ sed -i -e 's~\(setlocal fileencoding=utf-8\)~" \1~' ${f} \
+ || die "waah! bad sed voodoo. need more goats."
+ eend $?
+ done
+ fi
+}
+
+pkg_postinst() {
+ vim-plugin_pkg_postinst
+
+ if [[ -z ${REPLACING_VERSIONS} ]] ; then
+ if use ignore-glep31 1>/dev/null ; then
+ ewarn "You have chosen to disable the rules which ensure GLEP 31"
+ ewarn "compliance. When editing ebuilds, please make sure you get"
+ ewarn "the character set correct."
+ fi
+ fi
+}