summaryrefslogtreecommitdiff
path: root/app-vim/eruby-syntax/eruby-syntax-2.0-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-vim/eruby-syntax/eruby-syntax-2.0-r2.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-vim/eruby-syntax/eruby-syntax-2.0-r2.ebuild')
-rw-r--r--app-vim/eruby-syntax/eruby-syntax-2.0-r2.ebuild18
1 files changed, 18 insertions, 0 deletions
diff --git a/app-vim/eruby-syntax/eruby-syntax-2.0-r2.ebuild b/app-vim/eruby-syntax/eruby-syntax-2.0-r2.ebuild
new file mode 100644
index 000000000000..7062ef9a855c
--- /dev/null
+++ b/app-vim/eruby-syntax/eruby-syntax-2.0-r2.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: syntax highlighting for eruby"
+HOMEPAGE="https://www.vim.org/scripts/script.php?script_id=403"
+LICENSE="vim.org"
+KEYWORDS="alpha amd64 hppa ia64 ~mips ppc ppc64 sparc x86 ~x86-fbsd"
+
+VIM_PLUGIN_HELPTEXT="This plugin provides syntax highlighting for eruby"
+
+src_prepare() {
+ default
+ sed -i -e 's#hi link#hi def link#' syntax/eruby.vim || die "sed failed"
+}