summaryrefslogtreecommitdiff
path: root/app-vim/editorconfig-vim/editorconfig-vim-0.3.3-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-vim/editorconfig-vim/editorconfig-vim-0.3.3-r2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-vim/editorconfig-vim/editorconfig-vim-0.3.3-r2.ebuild')
-rw-r--r--app-vim/editorconfig-vim/editorconfig-vim-0.3.3-r2.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/app-vim/editorconfig-vim/editorconfig-vim-0.3.3-r2.ebuild b/app-vim/editorconfig-vim/editorconfig-vim-0.3.3-r2.ebuild
new file mode 100644
index 000000000000..af1907546c70
--- /dev/null
+++ b/app-vim/editorconfig-vim/editorconfig-vim-0.3.3-r2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=(python2_7 python3_4 python3_5 python3_6)
+inherit python-single-r1 vim-plugin
+
+DESCRIPTION="vim plugin: Support EditorConfig files "
+HOMEPAGE="http://editorconfig.org/"
+SRC_URI="https://github.com/${PN%-vim}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="
+ ${PYTHON_DEPS}
+ dev-python/editorconfig-core-py[${PYTHON_USEDEP}]
+ || (
+ app-editors/vim[python,${PYTHON_USEDEP}]
+ app-editors/gvim[python,${PYTHON_USEDEP}]
+ )"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${P}-python3.patch"
+ "${FILESDIR}/${P}-max-line-length-off.patch"
+ "${FILESDIR}/${P}-fixes.patch"
+)
+
+VIM_PLUGIN_HELPFILES="${PN%-vim}.txt"
+
+src_prepare() {
+ default
+
+ rm LICENSE mkzip.sh .editorconfig .gitignore .travis.yml || die
+ rm -r tests plugin/${PN%-vim}-core-py || die
+}