summaryrefslogtreecommitdiff
path: root/app-vim/cctree
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-15 04:49:10 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-15 04:49:10 +0100
commitefca79f216bfeffd55e7731fbf24126d093e1084 (patch)
treef19ba31d8686b3de4192db3e4c4dc9f3d9af54b5 /app-vim/cctree
parentea7f3f690b55cdfa8b2d350b03c1dfc0c8357a51 (diff)
gentoo auto-resync : 15:09:2023 - 04:49:10
Diffstat (limited to 'app-vim/cctree')
-rw-r--r--app-vim/cctree/Manifest1
-rw-r--r--app-vim/cctree/cctree-1.61-r2.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/app-vim/cctree/Manifest b/app-vim/cctree/Manifest
index 9500fc48cb9e..ee84781478b9 100644
--- a/app-vim/cctree/Manifest
+++ b/app-vim/cctree/Manifest
@@ -1,3 +1,4 @@
DIST cctree-1.61.tar.bz2 23243 BLAKE2B ba39d476ed68109a614cf5f626a44010aaa7e6154edf0c05f87973c46d95957a46fa22e29d73b0d3d602bae78039fd0bf6ef356d94f6570e0cea205bb6335572 SHA512 9d29c573ef3cdcde1ec91ca34684c84c8beb3b89669654b1f9dafab928a11d8f1df77294af06c7612ba8aa7d65dfba69352f3f74dd11c98d22a300907d8a6b0e
EBUILD cctree-1.61-r1.ebuild 804 BLAKE2B 5aaf44b8cbfcc0dee1470e55b2a946f796456707474c5ce433db2c6c4579ca31f04ff18b22e99cbb07d27115b9aa4224cbb606ab23694544b71f95f91789c252 SHA512 0eb287aa4d494e57248350888c311ebdb92dc4e86c3bb79b45da4e25fc9313dd115717a7f9e8522f254293ef64ef9446dd19689eff66a679798ebcf687b0aebc
+EBUILD cctree-1.61-r2.ebuild 796 BLAKE2B f2dd68b21fbe9676d94758098a5db5a337d153577f0a2919cedad47d7ee7d63d44b47edca5eed4b4032efb63e938bfaf85915a469fd5d9e8d6658f27088d0330 SHA512 ca4395ba5b80a342e012b44d862338c54ff7612cd5b1437e4a7cfdc3b5d158fcf54c7a507076cfa182dcd4515511a47f1525bc87fe24b9dbf939f6f3c25a0fb3
MISC metadata.xml 333 BLAKE2B c02947972a5dce67e6ef8dd7a24fcae5c16f2a1359e0eabe699ac2c031889abfbe440b2bc897a126f5f2de4c5e4aaf8c0e7a4c4e5577a8679c0f8a00a4440d53 SHA512 b13d0108b1f4c8077a5d3f5a1e1d36c6a66f05da4f6e83df4f63e13ae9df957ce83a901eeabeb51a10eea5e2b729477e3dee047522c17f67e4d70c9bc93a0d98
diff --git a/app-vim/cctree/cctree-1.61-r2.ebuild b/app-vim/cctree/cctree-1.61-r2.ebuild
new file mode 100644
index 000000000000..5f3cc27fb666
--- /dev/null
+++ b/app-vim/cctree/cctree-1.61-r2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: Cscope based source-code browser and code flow analysis tool"
+HOMEPAGE="https://sites.google.com/site/vimcctree/"
+
+LICENSE="bufexplorer.vim"
+KEYWORDS="~amd64 ~x86"
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+RDEPEND="dev-util/cscope"
+
+src_prepare() {
+ # There's good documentation included with the script, but it's not
+ # in a helpfile. Since there's rather too much information to include
+ # in a VIM_PLUGIN_HELPTEXT, we'll sed ourselves a help doc.
+ mkdir doc || die
+ sed -e '/" Name Of File/,/".\+Community/!d' -e 's/^" \?//' \
+ -e 's/\(Name Of File: \)\([^.]\+\)\.vim/\1*\L\2.txt*/' \
+ ftplugin/${PN}.vim > doc/${PN}.txt || die
+
+ default
+}