summaryrefslogtreecommitdiff
path: root/app-vim/automatictexplugin
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-vim/automatictexplugin
reinit the tree, so we can have metadata
Diffstat (limited to 'app-vim/automatictexplugin')
-rw-r--r--app-vim/automatictexplugin/Manifest5
-rw-r--r--app-vim/automatictexplugin/automatictexplugin-12.5-r1.ebuild34
-rw-r--r--app-vim/automatictexplugin/metadata.xml11
3 files changed, 50 insertions, 0 deletions
diff --git a/app-vim/automatictexplugin/Manifest b/app-vim/automatictexplugin/Manifest
new file mode 100644
index 000000000000..148334c66135
--- /dev/null
+++ b/app-vim/automatictexplugin/Manifest
@@ -0,0 +1,5 @@
+DIST AutomaticTexPlugin_12.5.tar.gz 442431 SHA256 1cec0d1573f33ec1afb1fb4171d12713f4b7e55841d16b0895805333eb781449 SHA512 93e48b3d7eb9bdc0319bf03d0ddc59f49c2aab63170030b4234fa83aa3aeb739f1384c4a94e09e630b82d328d9cbfbbdfbf493e6decff915ad9cd4d5b2fc3a5b WHIRLPOOL 3924add4e702ba5f5f08c21d06dea32ddf4c1d3f922536e14761b36d36b5408af7f252afba1603d49b5aaa456afb54c5457a9f9110c9bb61259c1aa6c53c4b90
+EBUILD automatictexplugin-12.5-r1.ebuild 825 SHA256 a26eaf0b39bd2bf841105d16f65a3f86b31cc07a668564dbd25a696908266fb8 SHA512 129af107a67db846ed10fb3b82b2e08e141d836b5d1ad673266457c5d3d05a658c6c48ccfb7efe722f229fe9baa376733efaad28bf72787b74a6ad36d3cfb442 WHIRLPOOL 54f2a58fe21e888966fba73a9fa687b099379411e0e27894ca93eba26b07d5afe00d43ff51655a46b6811f5ed1d5131d5a05932a10928a6f4d0bf9edf3310af1
+MISC ChangeLog 2463 SHA256 8f2deb27073156d32a1edc6947688de45b15da49a0589088c0b04291bb01e413 SHA512 5546e090bd1f789256630b0896cd1fea9cbf9875e41966f92c60d9b0e450e553fdfe1640e4f2d6be4c1f08fed90581ce775e9d6e7eeecf02fe611c2a1bc58a46 WHIRLPOOL 138a665794c1885ebfa9d4933b1a965c0797a4e704d0d47250cd42e7ce86bfaf93f3fbaa16837d902c0a86e4cd17f21f901fc25b13d3863d4bb1b757481b6811
+MISC ChangeLog-2015 7523 SHA256 4d1f01f5fdc7a50089ca09a12479d686ec5cc8a1e657f48da0b8ee5542c7f96a SHA512 ac8eddc33dfff7385a1410a381718a705023ae77048749ad3ea93ae8ad933946d7150cc7e98b90e6e4585015a4161a2eeafc8861fbef19cfdf6883d98850f0f8 WHIRLPOOL 8f22930deee544903782be54521dcf85ed6d34cced8b7ae43337a0fc963db8f1e602954ea162f2b6586d422f2633b76585b716570537815f13d8a466788ee1df
+MISC metadata.xml 326 SHA256 27dacf3c06002560b380705b40f93b9e3244a663d75aa580d14767a49624e6b3 SHA512 8ed4ff2cf60c6e0c39bb3c60c4f9ad4f1a5b6888192bb43fa9f0fb45efd89a549de839c60678bfbe6ed2353f594ea6b28b53f63ae2530650c0ea563325a0f5ff WHIRLPOOL 91500d7f9a3bf59354a52bffcc354148529b6699f07aa832ffae676cf8058d7a6bd4f8472b741fdb8a311c1236dca6cfc7b1bb38f281c766cb07904a983a78c2
diff --git a/app-vim/automatictexplugin/automatictexplugin-12.5-r1.ebuild b/app-vim/automatictexplugin/automatictexplugin-12.5-r1.ebuild
new file mode 100644
index 000000000000..d3a67dadea3a
--- /dev/null
+++ b/app-vim/automatictexplugin/automatictexplugin-12.5-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+inherit python-single-r1 vim-plugin
+
+MY_P="AutomaticTexPlugin_${PV}"
+DESCRIPTION="vim plugin: a comprehensive plugin for editing LaTeX files"
+HOMEPAGE="http://atp-vim.sourceforge.net/"
+SRC_URI="mirror://sourceforge/atp-vim/releases/${MY_P}.tar.gz"
+LICENSE="GPL-3"
+KEYWORDS="amd64 x86"
+
+S=${WORKDIR}
+
+VIM_PLUGIN_HELPFILES="automatic-tex-plugin.txt"
+
+RDEPEND="|| ( app-editors/vim[python,${PYTHON_USEDEP}] app-editors/gvim[python,${PYTHON_USEDEP}] )
+ !app-vim/vim-latex
+ app-vim/align
+ app-text/wdiff
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-tex/latexmk
+ dev-tex/detex
+ virtual/tex-base
+ ${PYTHON_DEPS}"
+
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+src_prepare() {
+ python_fix_shebang .
+}
diff --git a/app-vim/automatictexplugin/metadata.xml b/app-vim/automatictexplugin/metadata.xml
new file mode 100644
index 000000000000..037d63f53966
--- /dev/null
+++ b/app-vim/automatictexplugin/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>vim@gentoo.org</email>
+ <name>Gentoo Vim Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">atp-vim</remote-id>
+ </upstream>
+</pkgmetadata>