summaryrefslogtreecommitdiff
path: root/app-text
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-18 08:34:08 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-18 08:34:08 +0100
commit933ed80ab9b645de54b16eeb7410c0a54f47574f (patch)
treed954e8a97c73506c33035766b9578ece5d31667f /app-text
parent0b1a4d018ed7758b9e49f6e4b3b38304f91a8cf5 (diff)
gentoo auto-resync : 18:08:2022 - 08:34:07
Diffstat (limited to 'app-text')
-rw-r--r--app-text/Manifest.gzbin48385 -> 48382 bytes
-rw-r--r--app-text/lesspipe/Manifest2
-rw-r--r--app-text/lesspipe/lesspipe-2.06.ebuild52
-rw-r--r--app-text/lv/Manifest3
-rw-r--r--app-text/lv/lv-4.51-r4.ebuild49
-rw-r--r--app-text/lv/lv-4.51-r5.ebuild2
-rw-r--r--app-text/xdvik/Manifest3
-rw-r--r--app-text/xdvik/xdvik-22.87.03-r3.ebuild117
-rw-r--r--app-text/xdvik/xdvik-22.87.03-r4.ebuild2
9 files changed, 58 insertions, 172 deletions
diff --git a/app-text/Manifest.gz b/app-text/Manifest.gz
index 8c45e1fa59e0..7dabdddd1b52 100644
--- a/app-text/Manifest.gz
+++ b/app-text/Manifest.gz
Binary files differ
diff --git a/app-text/lesspipe/Manifest b/app-text/lesspipe/Manifest
index 3a54592dd637..a067009beef8 100644
--- a/app-text/lesspipe/Manifest
+++ b/app-text/lesspipe/Manifest
@@ -1,3 +1,5 @@
DIST lesspipe-2.05.tar.gz 167135 BLAKE2B 6f54a68a3857fcafa19148ba798d6ac49b2693e547e88a4a4fb6a178768d75ba8ae08e808a9e08aabfe903538bd401e3bd25e22ec240bf3a52365df729d87b9e SHA512 b4220b28fb609060735663067f5a738cae32d12e90efc397db3749e4dcfa7bfc063a4458c1f39b8a43be3b04effdc00a25c4feebd6e9a3b23f0064b879bbb698
+DIST lesspipe-2.06.tar.gz 168100 BLAKE2B a7447efa85cd422343f9dbb06001e85fa7b33c92db752f8248e4b4a0d9ecce4ef0241240d6993c5a71157c44da2f4ffc3efd41ac5e0a31e89ed5b80ac99f71fe SHA512 b2411c5e6b287fb67e1ea9b6d10377fe19b58e8c0f54587f825d1ee4c1a85f9a8ed3244a7cf339bcba960094e95821d9a56929951d862eb697f1d12fe55ef20d
EBUILD lesspipe-2.05.ebuild 1239 BLAKE2B 2265355eb134120872f08556c2835d08326842fd6e988cc5db9dbee8646370997c4499b2e7275637904ffef8ac836e7766a294a900a10d5a36a36309e6ca6c91 SHA512 b294b4a0aad7a1d20eefd74c93494fe73248b1e75710219575f70a5c6203da3c8a1db0b8e28f6b5f1c18e415238005546f6c87218a87fd038ffa66c664fcae7b
+EBUILD lesspipe-2.06.ebuild 1318 BLAKE2B 28c664aad8277a4a49d1cc432f255738156ef98b6268d362c3d583bd3f34b868ce6a02487aee8c3b53aa2dfcbeaf22271e336ae1dccdb9639f17dc0367fe69cc SHA512 3b7fb6d9d7216648e5c8b02553bd87a729639f7293c9b5dab51dc9a69dd5741bef81ed54739d593effa1b7305779bee67e83b6c4604488e885e1fce31756035f
MISC metadata.xml 304 BLAKE2B bb5be96b5fd22ce82d800f6bd5ed3ceb04b955182eaadc1f34b6f4b633c21efd6148013fc29b5567f7ada4da5de6efd7e0e420fa63a2976a5cf6bcf719c34f2e SHA512 2c217e67c6c487f7f7f98588a50086daf434bc25ad229b68d37bc12f7ecc4f904b5bc4a3b7b6db4a1daa0267c7e13fde8538de1c16d11e95be6b8071ee675105
diff --git a/app-text/lesspipe/lesspipe-2.06.ebuild b/app-text/lesspipe/lesspipe-2.06.ebuild
new file mode 100644
index 000000000000..b16b5f900cda
--- /dev/null
+++ b/app-text/lesspipe/lesspipe-2.06.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit bash-completion-r1
+
+DESCRIPTION="A preprocessor for less"
+HOMEPAGE="https://github.com/wofr06/lesspipe"
+SRC_URI="https://github.com/wofr06/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+
+# Please check again on bumps!
+# bug #734896
+RESTRICT="!test? ( test ) test"
+
+RDEPEND="dev-lang/perl"
+BDEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+ test? ( app-editors/vim )
+"
+
+src_configure() {
+ # Not an autoconf script.
+ ./configure --fixed || die
+}
+
+src_compile() {
+ # Nothing to build (avoids the "all" target)
+ :
+}
+
+src_install() {
+ emake PREFIX="${EPREFIX}/usr" DESTDIR="${D}" install
+ einstalldocs
+
+ rm -r "${ED}"/etc/bashcompletion.d || die
+ newbashcomp less_completion less
+}
+
+pkg_preinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]] ; then
+ elog "This package installs 'lesspipe.sh' which is distinct from 'lesspipe'."
+ elog "The latter is the Gentoo-specific version. Make sure to update your"
+ elog "LESSOPEN environment variable if you wish to use this copy."
+ fi
+}
diff --git a/app-text/lv/Manifest b/app-text/lv/Manifest
index 7fc3484e8f5c..0bd3167bdba5 100644
--- a/app-text/lv/Manifest
+++ b/app-text/lv/Manifest
@@ -3,6 +3,5 @@ AUX lv-headers.patch 725 BLAKE2B 64a570d256aae0e5d3c13c2c6a51c2311da1dff3057219f
AUX lv-tinfo.patch 629 BLAKE2B 1923de4cb256d6752561f2489d1633a01987e4ad073bd28fcafcd2ab81c68a2ea8a4a278a0c4a8c1c09df581f0391fb2c469c65144ddf5d7975ba1b8b9ae5555 SHA512 3a33edf5ad11d77cd23bd27fbe071aacf83ec5367b100103954159a0dc4ba2856f3978d3b8c7f41c52006dc99097bdd9d127419f700d75cbb88b745ffe4694e0
AUX lv-xz.patch 1415 BLAKE2B e4a9cbd5bb2ca71eb3c6eea8e132caf2f1bbfda84e8055654eac86948b7f0e57397af96beca2eeacf259f9258aafa5d03303a202ab5562236ba05f0adf22cfa7 SHA512 eb791a2e392070a01e372bbc6d0d4bc113fbb57394e50fb7a55e46ee4b0896177fdb1698db750b43e78b6aa120d0fef34ad4859fee5d4a1749c062a7afb6ec84
DIST lv451.tar.gz 605082 BLAKE2B cbfdf1c4c90dc746de631e55e3d1e88335f22342991ca7d5bd4b3661803af4efc0c6dcd821ea58be6024fa7ce773ffaa0aa3844350b6f67dd61be09e2475cb70 SHA512 88c05cb06ddc56e7f16f30b38218ec3bf9c8ef6c3c2b08d5a3f950b6870b82417368ada3f14f183b0feb6ed32d144d71901ad8134e5f88ddec11fc7b9520e810
-EBUILD lv-4.51-r4.ebuild 983 BLAKE2B 5b4fed1290923c58644aebe7b148f95acc4c02288c688f7127e1805d088a28533f80efd98fe7a02cf96e1c27f14629b4d835c5e90f81c2c91e8f2b4431f9f0a6 SHA512 5f7829327895e7681c91b35caaf2d42fc748adc1d3788f4363939e205b959b561ae57493416c548621e761716393e86b2dd1df0f2b649c2e43bfce1cdd8d3228
-EBUILD lv-4.51-r5.ebuild 932 BLAKE2B 173880a7c442d0b99e2117f7a34277ce2517d7701a253c838189feaf230382421aceaa155fc5c3b33e731ecd372ae95096e316b02da9dcde4ea3ca1457b6be6f SHA512 908ccad46f4a386d5b47a1532e9df2ddbabfa2ed976f915717fa2844dff83b268b82663f9d413d1eb95efeb5b173818b704053fa07932d72dc5269d0337df5fc
+EBUILD lv-4.51-r5.ebuild 931 BLAKE2B b776cac1368ca193fbf4f0faf29418a8dbd4bfa18e7cc7b7fe360fae9f63df2d09caef4b4dff414d21708ef3483b9a93b0fb3e2903be84096be524fb10d0eb22 SHA512 ab3be825da552f38e49ec87c3debdb0fffc06c7253defebbf816a5ae788ac1e43e0369e0bde7e74e96950ba52e1be5cd16163ee21dcaa53d62a004248d936525
MISC metadata.xml 241 BLAKE2B d06d8c9218cb9736ecc414504678e9bff30ba6bffbd2b357e9a2ea990df4e73a21b8ad4db267eddfdbf73e8501dabe5a748c4ea9d26906d39425ab744b320216 SHA512 cff6b46a252b531091d1ef597e3f714f98d2ef4aa621662d8c2ec15e4f990cd811300d3439e1be003bd307d0c8d12e78f34cf7fd49f6d006d9362f0e6ccf6252
diff --git a/app-text/lv/lv-4.51-r4.ebuild b/app-text/lv/lv-4.51-r4.ebuild
deleted file mode 100644
index 065e2cd8201a..000000000000
--- a/app-text/lv/lv-4.51-r4.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-
-inherit autotools toolchain-funcs
-
-MY_P="${PN}${PV//./}"
-
-DESCRIPTION="Powerful Multilingual File Viewer"
-#HOMEPAGE="http://www.ff.iij4u.or.jp/~nrt/lv/"
-HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
-SRC_URI="mirror://gentoo/${MY_P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 ~arm ~ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
-IUSE=""
-
-RDEPEND="!app-editors/levee
- sys-libs/ncurses:0="
-DEPEND="${RDEPEND}
- dev-lang/perl"
-S="${WORKDIR}/${MY_P}"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-gentoo.patch
- "${FILESDIR}"/${PN}-headers.patch
- "${FILESDIR}"/${PN}-tinfo.patch
- "${FILESDIR}"/${PN}-xz.patch
-)
-DOCS=( README hello.sample )
-HTML_DOCS=( index.html relnote.html hello.sample.gif )
-
-src_prepare() {
- default
-
- cd src
- mv configure.{in,ac}
- eautoreconf
-}
-
-src_configure() {
- ECONF_SOURCE=src econf
-}
-
-src_compile() {
- emake CC="$(tc-getCC)"
-}
diff --git a/app-text/lv/lv-4.51-r5.ebuild b/app-text/lv/lv-4.51-r5.ebuild
index 79220d164914..58fee6c0a2bb 100644
--- a/app-text/lv/lv-4.51-r5.ebuild
+++ b/app-text/lv/lv-4.51-r5.ebuild
@@ -13,7 +13,7 @@ SRC_URI="mirror://gentoo/${MY_P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~alpha amd64 ~arm ~ia64 ~ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
+KEYWORDS="~alpha amd64 ~arm ~ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
IUSE=""
RDEPEND="!app-editors/levee
diff --git a/app-text/xdvik/Manifest b/app-text/xdvik/Manifest
index 8afb82f37d04..624b17c49e29 100644
--- a/app-text/xdvik/Manifest
+++ b/app-text/xdvik/Manifest
@@ -1,6 +1,5 @@
AUX xdvik-22.87.03-freetype2-config.patch 1019 BLAKE2B a675a238fb147dcb67eda572b9a3b1e1b1ab630726464eb740240be0815b9a9da5e5f7a8a6d404648f060995c64efb02acbb67fc907dd6139c6817f0bdb5a946 SHA512 be5b7de6957c5bb2ad884e5b3a6a21f074b84b6be08f519b80a24dacd8630b2bc75dc64e225dba388d17a01bfed6784b2862db2e6bab4b73a1f6d4aebf23a9c6
AUX xdvik.xpm 3125 BLAKE2B 97990fbd5b22e51319c3f55bfe16808b01f215a92185a170620c8c0ef1dc44906e38af48ad056d4fb40a1777f92a88afaa0f80c0b36e7dd770954f7009d261a3 SHA512 697c888c481d7cbe7b42980d2ae93a8d25d781f926970d9040f8fbc6a37545349fbdbe2e8c98fb686e5a5ebe9a7a5ff661793d3a264fd8641182b0397365517d
DIST xdvik-22.87.03.tar.gz 4760306 BLAKE2B d242696fadf2980cd307d4a172d2af06d98d07b090279440117f869c9a623bcade8745d7a4d3c108c4eafbdeaadefb8d5ba1ea00bdf77d350cbf83c49c2ca0fb SHA512 d4d418d78658f16d4d278e387ed484b291afc8623b00acaf4110e9f123ed76568714ad50f80588373657f412e8fff36f3e76b3e43f69756d46f031c0f2269a88
-EBUILD xdvik-22.87.03-r3.ebuild 2905 BLAKE2B d3534e59c513372e72eaf48ed34b09b89542688deab3d03a22bbae30c45b991dd91a9fdcdc728a34ac1c0ff23572810e78731636893821d4aa779226f67205f4 SHA512 f871231eb081e65bf03dfcbdc9c09cc561a74074a806477132d5cd1ffff37fbc70aa62bfb15eba6978a49449ee78e5ba05d45ef5e20070ce23f0089478ffa989
-EBUILD xdvik-22.87.03-r4.ebuild 2842 BLAKE2B 328696c0f590562b8c71de725d226a1229560e00acd1b5d722b8cb374411e5d2d01abb3561f390bd7aa82a0d8ef18bb775c3a210d89646c37028b6642e9635b2 SHA512 0e171572e02d6fe9d037d00929c55aa127cc184ed5e8d98157081d1b7caa3806157fcf42b1613e9a9328060cc99ec1751259819af28d29f4df2cd4aa6af4e6b9
+EBUILD xdvik-22.87.03-r4.ebuild 2841 BLAKE2B 6bbf63451530616fea81800bfb65fb2f7c50972f3a6d93afd4cfeb99693c076731fc8ce68e4d9eff6edf1304b3cd20708d7c38c0ad44dae5646222e617c98208 SHA512 e1ba6154380b06671fe9fced1367d3ab46c0b2a77edae1dc10a3da88e53e7f4be390a4e0626fdc917e0943e2f8a274d3012cee1f8e6f42880e9a1da3a9270069
MISC metadata.xml 595 BLAKE2B 200debd0214e5985f3f59cabdac72252b556edef5224c77f5dbd91de347f57ab492dd0f7ce846c335179344bc9215b02af61572ff859c9c44ca947235ce5062b SHA512 bf925b9c9738c62f26ebbb2f88782597d6cee471a19258b553e0dc7aa397443149adfceba6cfcdd045196eecc3319541b980850ba5e572f51266da1945b65e4a
diff --git a/app-text/xdvik/xdvik-22.87.03-r3.ebuild b/app-text/xdvik/xdvik-22.87.03-r3.ebuild
deleted file mode 100644
index 6ae5639b5531..000000000000
--- a/app-text/xdvik/xdvik-22.87.03-r3.ebuild
+++ /dev/null
@@ -1,117 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit autotools desktop elisp-common flag-o-matic toolchain-funcs xdg-utils
-
-DESCRIPTION="DVI previewer for X Window System"
-HOMEPAGE="http://xdvi.sourceforge.net/"
-SRC_URI="mirror://sourceforge/xdvi/${P}.tar.gz"
-
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
-SLOT="0"
-LICENSE="GPL-2"
-IUSE="motif neXt Xaw3d emacs"
-
-CDEPEND=">=media-libs/freetype-2.9.1-r2:2
- x11-libs/libX11
- x11-libs/libXi
- x11-libs/libXmu
- x11-libs/libXpm
- x11-libs/libXt
- emacs? ( >=app-editors/emacs-23.1:* )
- motif? ( >=x11-libs/motif-2.3:0 )
- !motif? (
- neXt? ( x11-libs/neXtaw )
- !neXt? (
- Xaw3d? ( x11-libs/libXaw3d )
- !Xaw3d? ( x11-libs/libXaw )
- )
- )
- dev-libs/kpathsea:="
-DEPEND="sys-devel/flex
- virtual/yacc
- virtual/pkgconfig
- ${CDEPEND}"
-RDEPEND="${CDEPEND}
- virtual/latex-base
- !<app-text/texlive-2007"
-S=${WORKDIR}/${P}/texk/xdvik
-
-src_prepare() {
- local i
- # Make sure system kpathsea headers are used
- cd "${WORKDIR}/${P}/texk/kpathsea"
- for i in *.h ; do echo "#include_next \"$i\"" > $i; done
-
- cd "${WORKDIR}/${P}"
- eapply "${FILESDIR}"/${P}-freetype2-config.patch
- cd "${S}"
- eautoreconf
-
- eapply_user
-}
-
-src_configure() {
- has_version '>=dev-libs/kpathsea-6.2.1' && append-cppflags "$($(tc-getPKG_CONFIG) --cflags kpathsea)"
-
- local toolkit
-
- if use motif ; then
- toolkit="motif"
- use neXt && ewarn "neXt USE flag ignored (superseded by motif)"
- use Xaw3d && ewarn "Xaw3d USE flag ignored (superseded by motif)"
- elif use neXt ; then
- toolkit="neXtaw"
- use Xaw3d && ewarn "Xaw3d USE flag ignored (superseded by neXt)"
- elif use Xaw3d ; then
- toolkit="xaw3d"
- else
- toolkit="xaw"
- fi
-
- econf \
- --with-system-freetype2 \
- --with-system-kpathsea \
- --with-kpathsea-include="${EPREFIX}"/usr/include/kpathsea \
- --with-xdvi-x-toolkit="${toolkit}" \
- --x-includes="${SYSROOT}${EPREFIX}"/usr/include \
- --x-libraries="${SYSROOT}${EPREFIX}"/usr/$(get_libdir)
-}
-
-src_compile() {
- emake kpathsea_dir="${EPREFIX}/usr/include/kpathsea"
- use emacs && elisp-compile xdvi-search.el
-}
-
-src_install() {
- dodir /usr/share/texmf-dist/dvips/config
-
- emake DESTDIR="${D}" install
-
- dosym ../../texmf-dist/xdvi/XDvi /usr/share/X11/app-defaults/XDvi
-
- dodoc BUGS FAQ README.*
-
- use emacs && elisp-install tex-utils *.el *.elc
-
- doicon "${FILESDIR}"/${PN}.xpm
- make_desktop_entry xdvi "XDVI" xdvik "Graphics;Viewer"
- echo "MimeType=application/x-dvi;" >> "${ED}"usr/share/applications/xdvi-"${PN}".desktop
-}
-
-pkg_postinst() {
- xdg_desktop_database_update
-
- if use emacs; then
- elog "Add"
- elog " (add-to-list 'load-path \"${EPREFIX}${SITELISP}/tex-utils\")"
- elog " (require 'xdvi-search)"
- elog "to your ~/.emacs file"
- fi
-}
-
-pkg_postrm() {
- xdg_desktop_database_update
-}
diff --git a/app-text/xdvik/xdvik-22.87.03-r4.ebuild b/app-text/xdvik/xdvik-22.87.03-r4.ebuild
index 2f0571e7826e..7502839c86c5 100644
--- a/app-text/xdvik/xdvik-22.87.03-r4.ebuild
+++ b/app-text/xdvik/xdvik-22.87.03-r4.ebuild
@@ -10,7 +10,7 @@ HOMEPAGE="http://xdvi.sourceforge.net/"
SRC_URI="mirror://sourceforge/xdvi/${P}.tar.gz"
S="${WORKDIR}"/${P}/texk/xdvik
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ~ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
SLOT="0"
LICENSE="GPL-2"
IUSE="motif neXt Xaw3d emacs"