summaryrefslogtreecommitdiff
path: root/app-text/zathura-ps/zathura-ps-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-11-18 09:38:27 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-11-18 09:38:27 +0000
commit536c3711867ec947c1738f2c4b96f22e4863322d (patch)
tree697733f5cb713908dcf378e13fd15a798a906a91 /app-text/zathura-ps/zathura-ps-9999.ebuild
parentf65628136faa35d0c4d3b5e7332275c7b35fcd96 (diff)
gentoo resync : 18.11.2018
Diffstat (limited to 'app-text/zathura-ps/zathura-ps-9999.ebuild')
-rw-r--r--app-text/zathura-ps/zathura-ps-9999.ebuild47
1 files changed, 15 insertions, 32 deletions
diff --git a/app-text/zathura-ps/zathura-ps-9999.ebuild b/app-text/zathura-ps/zathura-ps-9999.ebuild
index 305bfa827e75..16e0d2d5ba33 100644
--- a/app-text/zathura-ps/zathura-ps-9999.ebuild
+++ b/app-text/zathura-ps/zathura-ps-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit eutils toolchain-funcs xdg
+inherit meson
if [[ ${PV} == *9999 ]]; then
inherit git-r3
@@ -11,38 +11,21 @@ if [[ ${PV} == *9999 ]]; then
EGIT_BRANCH="develop"
else
KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
- SRC_URI="https://pwmt.org/projects/zathura/plugins/download/${P}.tar.gz"
+ SRC_URI="https://pwmt.org/projects/zathura/plugins/download/${P}.tar.xz"
fi
DESCRIPTION="PostScript plug-in for zathura"
-HOMEPAGE="https://pwmt.org/projects/zathura/"
+HOMEPAGE="https://pwmt.org/projects/zathura-ps/download/"
LICENSE="ZLIB"
SLOT="0"
-IUSE=""
-
-RDEPEND=">=app-text/libspectre-0.2.6:=
- >=app-text/zathura-0.3.8
- dev-libs/glib:2=
- x11-libs/cairo:="
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-src_configure() {
- myzathuraconf=(
- CC="$(tc-getCC)"
- LD="$(tc-getLD)"
- VERBOSE=1
- DESTDIR="${D}"
- PREFIX="${EPREFIX}/usr"
- )
-}
-
-src_compile() {
- emake "${myzathuraconf[@]}"
-}
-
-src_install() {
- emake "${myzathuraconf[@]}" install
- dodoc AUTHORS
-}
+
+DEPEND="app-text/libspectre
+ >=app-text/zathura-0.3.9
+ dev-libs/girara
+ dev-libs/glib:2
+ x11-libs/cairo"
+
+RDEPEND="${DEPEND}"
+
+BDEPEND="virtual/pkgconfig"