summaryrefslogtreecommitdiff
path: root/app-text/zathura-ps/zathura-ps-0.2.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-10-22 11:09:47 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-10-22 11:09:47 +0100
commit64e107b9b6058580ff0432107eb37cefb0b2a7d8 (patch)
tree9a44e603e2ae365e2b1fe35ac37f73e830cdee1d /app-text/zathura-ps/zathura-ps-0.2.6.ebuild
parent957235cf19a691360c720f7913672adda4258ed0 (diff)
gentoo resync : 22.10.2018
Diffstat (limited to 'app-text/zathura-ps/zathura-ps-0.2.6.ebuild')
-rw-r--r--app-text/zathura-ps/zathura-ps-0.2.6.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-text/zathura-ps/zathura-ps-0.2.6.ebuild b/app-text/zathura-ps/zathura-ps-0.2.6.ebuild
new file mode 100644
index 000000000000..9a5fded445c1
--- /dev/null
+++ b/app-text/zathura-ps/zathura-ps-0.2.6.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://git.pwmt.org/pwmt/zathura-ps.git"
+ EGIT_BRANCH="develop"
+else
+ KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
+ SRC_URI="https://pwmt.org/projects/zathura/plugins/download/${P}.tar.xz"
+fi
+
+DESCRIPTION="PostScript plug-in for zathura"
+HOMEPAGE="https://pwmt.org/projects/zathura-ps/download/"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="app-text/libspectre
+ >=app-text/zathura-0.3.9
+ dev-libs/girara
+ dev-libs/glib:2
+ x11-libs/cairo"
+
+RDEPEND="${DEPEND}"
+
+BDEPEND="virtual/pkgconfig"