summaryrefslogtreecommitdiff
path: root/app-text/zathura-pdf-mupdf/zathura-pdf-mupdf-0.3.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-text/zathura-pdf-mupdf/zathura-pdf-mupdf-0.3.1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-text/zathura-pdf-mupdf/zathura-pdf-mupdf-0.3.1.ebuild')
-rw-r--r--app-text/zathura-pdf-mupdf/zathura-pdf-mupdf-0.3.1.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/app-text/zathura-pdf-mupdf/zathura-pdf-mupdf-0.3.1.ebuild b/app-text/zathura-pdf-mupdf/zathura-pdf-mupdf-0.3.1.ebuild
new file mode 100644
index 000000000000..28291c0f627f
--- /dev/null
+++ b/app-text/zathura-pdf-mupdf/zathura-pdf-mupdf-0.3.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+[[ ${PV} == 9999* ]] && inherit git-2
+
+DESCRIPTION="PDF plug-in for zathura"
+HOMEPAGE="http://pwmt.org/projects/zathura/"
+if ! [[ ${PV} == 9999* ]]; then
+SRC_URI="http://pwmt.org/projects/zathura/plugins/download/${P}.tar.gz"
+fi
+EGIT_REPO_URI="https://git.pwmt.org/pwmt/${PN}.git"
+EGIT_BRANCH="develop"
+
+LICENSE="ZLIB"
+SLOT="0"
+if ! [[ ${PV} == 9999* ]]; then
+KEYWORDS="amd64 arm x86"
+fi
+IUSE=""
+
+RDEPEND="!app-text/zathura-pdf-poppler
+ >=app-text/mupdf-1.10a:=
+ >=app-text/zathura-0.3.1
+ media-libs/jbig2dec:=
+ media-libs/openjpeg:2=
+ virtual/jpeg:0
+ x11-libs/cairo:="
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+pkg_setup() {
+ myzathuraconf=(
+ CC="$(tc-getCC)"
+ LD="$(tc-getLD)"
+ VERBOSE=1
+ DESTDIR="${D}"
+ MUPDF_LIB="$($(tc-getPKG_CONFIG) --libs mupdf)"
+ OPENSSL_INC="$($(tc-getPKG_CONFIG) --cflags mupdf)"
+ OPENSSL_LIB=''
+ )
+}
+
+src_compile() {
+ emake "${myzathuraconf[@]}"
+}
+
+src_install() {
+ emake "${myzathuraconf[@]}" install
+ dodoc AUTHORS
+}