summaryrefslogtreecommitdiff
path: root/app-text/zathura-cb/zathura-cb-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-11-18 09:38:27 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-11-18 09:38:27 +0000
commit536c3711867ec947c1738f2c4b96f22e4863322d (patch)
tree697733f5cb713908dcf378e13fd15a798a906a91 /app-text/zathura-cb/zathura-cb-9999.ebuild
parentf65628136faa35d0c4d3b5e7332275c7b35fcd96 (diff)
gentoo resync : 18.11.2018
Diffstat (limited to 'app-text/zathura-cb/zathura-cb-9999.ebuild')
-rw-r--r--app-text/zathura-cb/zathura-cb-9999.ebuild56
1 files changed, 14 insertions, 42 deletions
diff --git a/app-text/zathura-cb/zathura-cb-9999.ebuild b/app-text/zathura-cb/zathura-cb-9999.ebuild
index f1483517b654..5e59ea0d4e25 100644
--- a/app-text/zathura-cb/zathura-cb-9999.ebuild
+++ b/app-text/zathura-cb/zathura-cb-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit eutils toolchain-funcs readme.gentoo-r1 xdg
+inherit meson
if [[ ${PV} == *9999 ]]; then
inherit git-r3
@@ -11,48 +11,20 @@ if [[ ${PV} == *9999 ]]; then
EGIT_BRANCH="develop"
else
KEYWORDS="~amd64 ~arm ~x86"
- SRC_URI="https://pwmt.org/projects/zathura/plugins/download/${P}.tar.gz"
+ SRC_URI="https://pwmt.org/projects/zathura/plugins/download/${P}.tar.xz"
fi
DESCRIPTION="Comic book plug-in for zathura with 7zip, rar, tar and zip support"
-HOMEPAGE="https://pwmt.org/projects/zathura/"
+HOMEPAGE="https://pwmt.org/projects/zathura-cb/"
LICENSE="ZLIB"
SLOT="0"
-IUSE=""
-
-RDEPEND=">=app-text/zathura-0.3.8
- dev-libs/glib:2=
- app-arch/libarchive:=
- x11-libs/cairo:=
- x11-libs/gdk-pixbuf:="
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-src_configure() {
- myzathuraconf=(
- CC="$(tc-getCC)"
- LD="$(tc-getLD)"
- VERBOSE=1
- DESTDIR="${D}"
- )
-}
-
-src_compile() {
- emake "${myzathuraconf[@]}"
-}
-
-src_install() {
- emake "${myzathuraconf[@]}" install
- dodoc AUTHORS
-
- FORCE_PRINT_ELOG=1
- local DOC_CONTENTS="Consider installing app-arch/p7zip app-arch/tar app-arch/unrar
- app-arch/unzip for additional file support."
- readme.gentoo_create_doc
-}
-
-pkg_postinst() {
- xdg_pkg_postinst
- readme.gentoo_print_elog
-}
+
+DEPEND=">=app-text/zathura-0.3.9
+ dev-libs/girara
+ dev-libs/glib:2
+ x11-libs/cairo"
+
+RDEPEND="${DEPEND}"
+
+BDEPEND="virtual/pkgconfig"