summaryrefslogtreecommitdiff
path: root/app-text/xournalpp/xournalpp-1.1.1-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-29 03:16:09 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-29 03:16:09 +0100
commit2d3042634af4767714cb90eff3f773ef54afb5ed (patch)
tree52df7aa6b75899440a32b7c80c8d7015adaf4524 /app-text/xournalpp/xournalpp-1.1.1-r3.ebuild
parent14bda3c9c57c13e8a59303f400678313fd770bdd (diff)
gentoo auto-resync : 29:05:2023 - 03:16:09
Diffstat (limited to 'app-text/xournalpp/xournalpp-1.1.1-r3.ebuild')
-rw-r--r--app-text/xournalpp/xournalpp-1.1.1-r3.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/app-text/xournalpp/xournalpp-1.1.1-r3.ebuild b/app-text/xournalpp/xournalpp-1.1.1-r3.ebuild
new file mode 100644
index 000000000000..cd729ea77198
--- /dev/null
+++ b/app-text/xournalpp/xournalpp-1.1.1-r3.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# Upstream only support 5.3 (see CMakeLists.txt), also bug #854615
+LUA_COMPAT=( lua5-3 )
+inherit cmake lua-single xdg
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/xournalpp/xournalpp.git"
+else
+ SRC_URI="https://github.com/xournalpp/xournalpp/archive/refs/tags/v${PV}.tar.gz -> ${P}.tgz"
+ KEYWORDS="amd64 ~ppc64"
+fi
+
+DESCRIPTION="Handwriting notetaking software with PDF annotation support"
+HOMEPAGE="https://github.com/xournalpp/xournalpp"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+REQUIRED_USE="${LUA_REQUIRED_USE}"
+
+COMMON_DEPEND="
+ ${LUA_DEPS}
+ app-text/poppler[cairo]
+ dev-libs/glib
+ dev-libs/libxml2
+ dev-libs/libzip:=
+ gnome-base/librsvg
+ media-libs/portaudio[cxx]
+ media-libs/libsndfile
+ sys-libs/zlib:=
+ x11-libs/gtk+:3
+"
+RDEPEND="${COMMON_DEPEND}"
+DEPEND="${COMMON_DEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ sys-apps/lsb-release
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.1.1-nostrip.patch"
+ "${FILESDIR}/${PN}-1.1.1-nocompress.patch"
+)