summaryrefslogtreecommitdiff
path: root/app-text/xournal/xournal-0.4.8-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-text/xournal/xournal-0.4.8-r1.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-text/xournal/xournal-0.4.8-r1.ebuild')
-rw-r--r--app-text/xournal/xournal-0.4.8-r1.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/app-text/xournal/xournal-0.4.8-r1.ebuild b/app-text/xournal/xournal-0.4.8-r1.ebuild
new file mode 100644
index 000000000000..69d6ceebd250
--- /dev/null
+++ b/app-text/xournal/xournal-0.4.8-r1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+GCONF_DEBUG=no
+
+[[ ${PV} == *9999 ]] && GNOME2_EAUTORECONF=yes
+
+inherit gnome2
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://git.code.sf.net/p/xournal/code"
+ unset SRC_URI
+else
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+fi
+
+DESCRIPTION="An application for notetaking, sketching, and keeping a journal using a stylus"
+HOMEPAGE="http://xournal.sourceforge.net/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="+pdf vanilla"
+
+COMMONDEPEND="
+ app-text/poppler[cairo]
+ dev-libs/atk
+ dev-libs/glib
+ gnome-base/libgnomecanvas
+ media-libs/freetype
+ media-libs/fontconfig
+ sys-libs/zlib
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf
+ x11-libs/gtk+:2
+ x11-libs/pango
+"
+RDEPEND="${COMMONDEPEND}
+ pdf? ( app-text/poppler[utils] app-text/ghostscript-gpl )
+"
+DEPEND="${COMMONDEPEND}
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ default_src_prepare
+ if ! use vanilla; then
+ epatch "${FILESDIR}"/xournal-0.4.8-aspectratio.patch
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ emake DESTDIR="${D}" desktop-install
+
+ dodoc ChangeLog AUTHORS README
+ dohtml -r html-doc/*
+}