summaryrefslogtreecommitdiff
path: root/app-text/xournal/xournal-0.4.8-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-text/xournal/xournal-0.4.8-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-text/xournal/xournal-0.4.8-r1.ebuild')
-rw-r--r--app-text/xournal/xournal-0.4.8-r1.ebuild63
1 files changed, 63 insertions, 0 deletions
diff --git a/app-text/xournal/xournal-0.4.8-r1.ebuild b/app-text/xournal/xournal-0.4.8-r1.ebuild
new file mode 100644
index 000000000000..2d7a90544031
--- /dev/null
+++ b/app-text/xournal/xournal-0.4.8-r1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+GCONF_DEBUG=no
+
+inherit gnome2
+
+DESCRIPTION="An application for notetaking, sketching, and keeping a journal using a stylus"
+HOMEPAGE="http://xournal.sourceforge.net/"
+
+LICENSE="GPL-2"
+
+SLOT="0"
+IUSE="+pdf vanilla"
+
+if [[ "${PV}" != "9999" ]]; then
+ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+else
+ inherit git-2 autotools
+ SRC_URI=""
+ KEYWORDS=""
+ EGIT_REPO_URI="git://git.code.sf.net/p/xournal/code"
+ EGIT_PROJECT="${PN}"
+ EGIT_BOOTSTRAP="autogen.sh"
+fi
+
+COMMONDEPEND="
+ app-text/poppler:=[cairo]
+ dev-libs/atk
+ dev-libs/glib
+ gnome-base/libgnomecanvas
+ media-libs/freetype
+ media-libs/fontconfig
+ sys-libs/zlib
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf
+ x11-libs/gtk+:2
+ x11-libs/pango
+"
+RDEPEND="${COMMONDEPEND}
+ pdf? ( app-text/poppler[utils] app-text/ghostscript-gpl )
+"
+DEPEND="${COMMONDEPEND}
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ default_src_prepare
+ if ! use vanilla; then
+ epatch "${FILESDIR}"/xournal-0.4.8-aspectratio.patch
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ emake DESTDIR="${D}" desktop-install
+
+ dodoc ChangeLog AUTHORS README
+ dohtml -r html-doc/*
+}