summaryrefslogtreecommitdiff
path: root/app-text/xmlto/xmlto-0.0.28-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /app-text/xmlto/xmlto-0.0.28-r3.ebuild
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'app-text/xmlto/xmlto-0.0.28-r3.ebuild')
-rw-r--r--app-text/xmlto/xmlto-0.0.28-r3.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/app-text/xmlto/xmlto-0.0.28-r3.ebuild b/app-text/xmlto/xmlto-0.0.28-r3.ebuild
new file mode 100644
index 000000000000..5602e66567e0
--- /dev/null
+++ b/app-text/xmlto/xmlto-0.0.28-r3.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit eutils
+
+DESCRIPTION="script for converting XML and DocBook documents to a variety of output formats"
+HOMEPAGE="https://pagure.io/xmlto"
+SRC_URI="https://releases.pagure.org/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="latex text"
+
+RDEPEND=">=app-text/docbook-xsl-stylesheets-1.62.0-r1
+ app-text/docbook-xml-dtd:4.2
+ app-shells/bash:0
+ dev-libs/libxslt
+ sys-apps/sed
+ >=sys-apps/coreutils-6.10-r1
+ || ( sys-apps/util-linux app-misc/getopt )
+ sys-apps/which
+ text? ( || ( virtual/w3m www-client/lynx www-client/elinks ) )
+ latex? ( dev-texlive/texlive-formatsextra )"
+# We only depend on flex when we patch the imput lexer.
+DEPEND="${RDEPEND}"
+
+DOCS="AUTHORS ChangeLog FAQ NEWS README THANKS"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.0.22-format_fo_passivetex_check.patch
+
+ # fix symbol clash on Solaris
+ if [[ ${CHOST} == *-solaris* ]] ; then
+ sed -i -e 's/\(attrib\|val\)/XMLTO\1/g' xmlif/xmlif.l || die
+ fi
+}
+
+src_configure() {
+ # We don't want the script to detect /bin/sh if it is bash.
+ export ac_cv_path_BASH=${BASH}
+ has_version sys-apps/util-linux || export GETOPT=getopt-long
+ econf
+}