summaryrefslogtreecommitdiff
path: root/app-text/xmlstarlet
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-02-13 21:41:11 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-02-13 21:41:11 +0000
commitc8d60dada2ec8eb48b2d2b290cd6683ccec40e39 (patch)
treec44943ee0563a3fa957716de909fed683117fcb9 /app-text/xmlstarlet
parent69051588e2f955485fe5d45d45e616bc60a2de57 (diff)
gentoo (valentine's day) resync : 14.02.2021
Diffstat (limited to 'app-text/xmlstarlet')
-rw-r--r--app-text/xmlstarlet/Manifest2
-rw-r--r--app-text/xmlstarlet/xmlstarlet-1.6.1.ebuild18
2 files changed, 17 insertions, 3 deletions
diff --git a/app-text/xmlstarlet/Manifest b/app-text/xmlstarlet/Manifest
index 1332622364d9..350098032456 100644
--- a/app-text/xmlstarlet/Manifest
+++ b/app-text/xmlstarlet/Manifest
@@ -1,3 +1,3 @@
DIST xmlstarlet-1.6.1.tar.gz 420923 BLAKE2B 56bf29f62549a7445e3cf15b6a3f60558dbcacf96645c3acc5a45b432d61f47614274a5d3e7234399f7dbdb854b503d73a6cfb8989710b7363d743dce4dff8f0 SHA512 4228df812caec7059d7a76986c4d9a4262bd861cc53dca05f341ae6c062be05f1c39fc637918ab00f60f40587c6c556e3c9bfaf8a18b149e3c321a92214dbe8b
-EBUILD xmlstarlet-1.6.1.ebuild 940 BLAKE2B fb6b9231426bd38188a6fd3c7e18ad6b1d7af6dd4af2964ec278d81717f99c9f8366e21a6d505edf9ddd398fdb578d20c817c7f4cb6572612c7580781c1f0035 SHA512 891edcde0d98e75bd4eef3fbe640d40f68e772579a1d07c1241d39ab599f6704ea8987e1e02689d0fae8d709b3cb31d7f56991fb708a2ae619457ec0205688b3
+EBUILD xmlstarlet-1.6.1.ebuild 1446 BLAKE2B f9a6499dccb3edcba02665bdc94f2c06b0b3ebb9c65489efa31fef03e70f2954869eaab555532527c184523d15bcbe43bb17a46749c0e0465cc3087bf820c5aa SHA512 16ff0d0dbabc518687cee24decdaab3546c0c595373aaefdc4d618c75a27185183374211ba086037848da2b71df641789a56b8ee35e73a26bc2d4569f5223904
MISC metadata.xml 293 BLAKE2B 1e39cff7005653b64f2f27c49262c0ae492da15d33d361e5e9b4148a3e975db2b30e26468fe5cf7f61155f53a3f76a16121b8a4c85ae5420d0ec74885d33bba9 SHA512 9fd9f809f74a272cc9abb789f3e08ab9b2ecdd1f6ca3931f43567b3b2e3423c0622bd3cc52f5dceac6989282351400fe9c1554ec2b69439986902b11f589796d
diff --git a/app-text/xmlstarlet/xmlstarlet-1.6.1.ebuild b/app-text/xmlstarlet/xmlstarlet-1.6.1.ebuild
index c2ad4628c946..0ff17e1a8107 100644
--- a/app-text/xmlstarlet/xmlstarlet-1.6.1.ebuild
+++ b/app-text/xmlstarlet/xmlstarlet-1.6.1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit flag-o-matic toolchain-funcs
+inherit autotools multilib flag-o-matic toolchain-funcs
DESCRIPTION="A set of tools to transform, query, validate, and edit XML documents"
HOMEPAGE="http://xmlstar.sourceforge.net/"
@@ -21,6 +21,20 @@ RDEPEND="
DEPEND="${RDEPEND}"
BDEPEND="virtual/pkgconfig"
+src_prepare() {
+ default
+
+ # We need to patch use of /usr/lib because it is a problem with
+ # linker lld with profile 17.1 on amd64 (see https://bugs.gentoo.org/729600).
+ # The grep sandwich acts as a regression test so that a future
+ # version bump cannot break patching without noticing.
+ grep -wq _PREFIX/lib m4/xstar-check-libs.m4 || die
+ sed "s,_PREFIX/lib,_PREFIX/$(get_libdir)," -i m4/xstar-check-libs.m4 || die
+ grep -w _PREFIX/lib m4/xstar-check-libs.m4 && die
+
+ eautoreconf
+}
+
src_configure() {
append-cppflags $($(tc-getPKG_CONFIG) --cflags libxml-2.0)