summaryrefslogtreecommitdiff
path: root/app-text/xmlformat/xmlformat-1.04.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:56:41 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:56:41 +0100
commitd87262dd706fec50cd150aab3e93883b6337466d (patch)
tree246b44c33ad7a57550430b0a60fa0df86a3c9e68 /app-text/xmlformat/xmlformat-1.04.ebuild
parent71bc00c87bba1ce31de0dac6c3b7fd1aee6917fc (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-text/xmlformat/xmlformat-1.04.ebuild')
-rw-r--r--app-text/xmlformat/xmlformat-1.04.ebuild51
1 files changed, 0 insertions, 51 deletions
diff --git a/app-text/xmlformat/xmlformat-1.04.ebuild b/app-text/xmlformat/xmlformat-1.04.ebuild
deleted file mode 100644
index b91035f55bd4..000000000000
--- a/app-text/xmlformat/xmlformat-1.04.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-USE_RUBY="ruby22 ruby23 ruby24 ruby25"
-
-inherit ruby-single
-
-DESCRIPTION="Reformat XML documents to your custom style"
-SRC_URI="http://www.kitebird.com/software/${PN}/${P}.tar.gz"
-HOMEPAGE="http://www.kitebird.com/software/xmlformat/"
-
-SLOT="0"
-LICENSE="xmlformat"
-KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
-
-DEPEND="ruby? ( ${RUBY_DEPS} )
- !ruby? ( dev-lang/perl )"
-RDEPEND=${DEPEND}
-IUSE="ruby doc"
-
-src_install() {
- dobin xmlformat.pl
-
- if use ruby
- then
- dobin xmlformat.rb
- dosym xmlformat.rb /usr/bin/xmlformat
- else
- dosym xmlformat.pl /usr/bin/xmlformat
- fi
-
- dodoc BUGS ChangeLog README TODO
-
- if use doc
- then
- # APIs
- insinto /usr/share/doc/${PF}
- doins -r docs/*
- fi
-}
-
-src_test() {
- if use ruby
- then
- ./runtest all || die "runtest for ruby failed."
- else
- ./runtest -p all || die "runtest for perl failed."
- fi
-}