summaryrefslogtreecommitdiff
path: root/app-text/xml2doc
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-text/xml2doc
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-text/xml2doc')
-rw-r--r--app-text/xml2doc/Manifest4
-rw-r--r--app-text/xml2doc/files/xml2doc-pointer_fix.patch20
-rw-r--r--app-text/xml2doc/metadata.xml8
-rw-r--r--app-text/xml2doc/xml2doc-20030510-r1.ebuild59
4 files changed, 91 insertions, 0 deletions
diff --git a/app-text/xml2doc/Manifest b/app-text/xml2doc/Manifest
new file mode 100644
index 000000000000..cede4b7ac543
--- /dev/null
+++ b/app-text/xml2doc/Manifest
@@ -0,0 +1,4 @@
+AUX xml2doc-pointer_fix.patch 627 BLAKE2B 3ca9313b44d88fce3f548874d40ed57b42b9faa66e30574677c911f7d5c9d0a8d5eea8c35781162302543df82c5b38b1327fcaabee0a50c396c95937c3a86e44 SHA512 ebdf69986821fdb1a22e3da4447729433d7f30d08e516b5b28c1f9e4fe6ec98d7a31e925028f940e8a0aaab5c05bd52a1a4d12564fd47a79953b1de606fd2430
+DIST xml2doc-20030510.tgz 53307 BLAKE2B 3f7e44ede6ac0a2ec4762e66181de34ffe553035b54ee302345d1b38a5063106fc4ba65abec042b4ec693b173d70fc4b548ebc942b2a8f6636f84e7beeed2bd6 SHA512 9eb2970b7adef1669b9b0aede2b3d2b42ba234c8294f0f8e6e230d8fcc6cf878675b2f0bff87ee36a255ab29376be844d92d382be7aad0ab11972847cfe49dbd
+EBUILD xml2doc-20030510-r1.ebuild 1217 BLAKE2B 7b48db570d5435d43d48d03e53ee8231aefa570fee8a1965abadfbc0078576575fdeae11af3a0018bc15081cf2455aeb80e22ee49ff56755e763c678e3d0f79c SHA512 19ef01d4a2a2ecf59122073e060ee0b13208a113d3839f71969509cfcef3e12597c37963a77daaa3be5223ec40bc9351ddb583ad680e549354dfc9e36535f07e
+MISC metadata.xml 244 BLAKE2B 6c0f152456a096c4bfbf861d8d7db04d0b8c605deb5f9a3277cd6b60df4a714c77bb12d5e4a491a193da11883447855986468ecf5c707600febbed973253181d SHA512 b4abe1dd13476a480e518e284cb832c2b41893049169975ee44edba8661af79b7cd8f8110e03b920fe90cd8e0e1d926bd5a692a24ecb841bd454659de3422ee9
diff --git a/app-text/xml2doc/files/xml2doc-pointer_fix.patch b/app-text/xml2doc/files/xml2doc-pointer_fix.patch
new file mode 100644
index 000000000000..b6adabe3c1a3
--- /dev/null
+++ b/app-text/xml2doc/files/xml2doc-pointer_fix.patch
@@ -0,0 +1,20 @@
+diff -NurdpB xml2doc/src/output_info.c xml2doc-patched/src/output_info.c
+--- xml2doc/src/output_info.c 2003-04-25 05:11:27.000000000 -0500
++++ xml2doc-patched/src/output_info.c 2007-03-14 15:07:59.000000000 -0500
+@@ -9,11 +9,11 @@ void output_info()
+ *subject = xmlGetProp(Doc[n].cur,"subject"),
+ *keywords = xmlGetProp(Doc[n].cur,"keywords"),
+ *trapped = xmlGetProp(Doc[n].cur,"trapped");
+- struct time_t *timet;
+- struct tm *clk;
+-
+- time((time_t *)&timet);
+- clk=localtime((const time_t *)&timet);
++ time_t timet;
++ struct tm *clk;
++
++ time(&timet);
++ clk=localtime(&timet);
+
+ switch(DocS.output)
+ {
diff --git a/app-text/xml2doc/metadata.xml b/app-text/xml2doc/metadata.xml
new file mode 100644
index 000000000000..6109befef74c
--- /dev/null
+++ b/app-text/xml2doc/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <!-- maintainer-needed -->
+ <upstream>
+ <remote-id type="sourceforge">xml2doc</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-text/xml2doc/xml2doc-20030510-r1.ebuild b/app-text/xml2doc/xml2doc-20030510-r1.ebuild
new file mode 100644
index 000000000000..ee66dcf4fb06
--- /dev/null
+++ b/app-text/xml2doc/xml2doc-20030510-r1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Tool to convert simple XML to a variety of formats (pdf, html, txt, manpage)"
+
+HOMEPAGE="http://xml2doc.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
+
+LICENSE="GPL-2"
+IUSE=""
+SLOT="0"
+
+KEYWORDS="alpha amd64 ~hppa ia64 ~mips ppc ppc64 sparc x86"
+
+DEPEND=">=dev-libs/libxml2-2.5"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ # Fix pointer-related bug detected by a QA notice.
+ epatch "${FILESDIR}/${PN}-pointer_fix.patch"
+
+ # Don't strip symbols from binary (bug #152266)
+ sed -i -e '/^\s*strip/d' \
+ -e 's/^\t$(CC) $(LFLAGS).*/\t$(LINK.o) $(L_PDF) $^ -lxml2 -o $(BIN)/' \
+ -e '/^\t$(CC) $(CFLAGS) /d' \
+ src/Makefile.in
+}
+
+src_configure() {
+ econf --disable-pdf
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+
+ cd "${S}/doc"
+ "${S}"/src/xml2doc -oM manpage.xml xml2doc.1 || die
+}
+
+src_install() {
+ # xml2doc's make install is unfortunately broken
+
+ # binary
+ dobin src/xml2doc || die
+
+ # documentation
+ dodoc BUGS README TODO || die
+ docinto examples
+ dodoc examples/*.{xml,png} || die
+
+ # manpage
+ doman doc/xml2doc.1 || die
+}