summaryrefslogtreecommitdiff
path: root/app-text/xlhtml
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-text/xlhtml
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-text/xlhtml')
-rw-r--r--app-text/xlhtml/Manifest4
-rw-r--r--app-text/xlhtml/metadata.xml8
-rw-r--r--app-text/xlhtml/xlhtml-0.5.1_p6.ebuild44
3 files changed, 56 insertions, 0 deletions
diff --git a/app-text/xlhtml/Manifest b/app-text/xlhtml/Manifest
new file mode 100644
index 000000000000..ad382167c7e3
--- /dev/null
+++ b/app-text/xlhtml/Manifest
@@ -0,0 +1,4 @@
+DIST xlhtml_0.5.1-6.diff.gz 119282 BLAKE2B 032ba3c27a8d1d8b3b0bc40b30d137ff03f6b3d2d6dd0cec00203d705fd70fbf926e737536829e3aeeb3592a157402ce49c0754e5b232df3d28aee046141b5ad SHA512 f1f4bba58858e6033f164e689333904887b7cd60bf082e2247e7fe0c54f3737e72aff6590deefd1d8a04d4b25d27631664594c50c9cc4bbdc8c9b20c6ccce7bd
+DIST xlhtml_0.5.1.orig.tar.gz 263933 BLAKE2B 88d08e4e3dd573136f8a7ef27038b80bf8dde14f648e200f1673e1a83ebcd4ba085f3073d51f0473e5ca45e731414bad5bf00381dd7c56b369311cb6473342c7 SHA512 9ac1cafd4496293cbc5ca9109a8d467fab6dd24c1daa91754b7f49502e2607272292b8bb9ed876b21fe1b287ef3293a0f6c5882c18a18fd715137c27d63f9f01
+EBUILD xlhtml-0.5.1_p6.ebuild 969 BLAKE2B f1a7ff55f6ec192c2ec329951097dc35f0907b228cbdb61f19d9c25c663882125af1244ae553a1e5fbd79ffd3dc972de5387ebfbbc4a6e298768c1c05181596f SHA512 7041a06c8a35e5c268e0ee4377cee1980a4f812184dfa27ebbeb363f845fac4e15f01799627ffa229e335e70979681d49db5cfcc022615fa921adc07fa45e178
+MISC metadata.xml 249 BLAKE2B 31251b3297cc7eb5625140690803a9f0f7471c492eb02f10594f5031c5ca133bd409f65d9285644c6c3fadd1af1155a4946d0935feba73a3c90c4d95f60889fa SHA512 f6d4ee96a09d5be353d8965ce7944db541bfd6fbe75e2a80dd660993e36250fe146c30ca914667c0d09ae3916274295661f2a6b0b1bc1c2fcc0123a7cde2b3a6
diff --git a/app-text/xlhtml/metadata.xml b/app-text/xlhtml/metadata.xml
new file mode 100644
index 000000000000..093eecf6e488
--- /dev/null
+++ b/app-text/xlhtml/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <!-- maintainer-needed -->
+ <upstream>
+ <remote-id type="sourceforge">chicago</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-text/xlhtml/xlhtml-0.5.1_p6.ebuild b/app-text/xlhtml/xlhtml-0.5.1_p6.ebuild
new file mode 100644
index 000000000000..eb983af44ba3
--- /dev/null
+++ b/app-text/xlhtml/xlhtml-0.5.1_p6.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit autotools eutils
+
+MY_PV=${PV/_p*/}
+DEB_PR=${PV/*_p/}
+
+DESCRIPTION="Convert MS Excel and Powerpoint files to HTML"
+HOMEPAGE="http://chicago.sourceforge.net/xlhtml/ http://packages.debian.org/etch/xlhtml/"
+SRC_URI="
+ mirror://debian/pool/main/${PN:0:1}/${PN}/${PN}_${MY_PV}.orig.tar.gz
+ mirror://debian/pool/main/${PN:0:1}/${PN}/${PN}_${MY_PV}-${DEB_PR}.diff.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 ppc sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE=""
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ ecvs_clean
+ epatch "${WORKDIR}"/${PN}_${MY_PV}-${DEB_PR}.diff
+
+ mv configure.{in,ac} || die
+
+ eautoreconf
+}
+
+src_install() {
+ default
+
+ docinto cole
+ dodoc cole/{AUTHORS,COPYING,NEWS,ChangeLog,THANKS,TODO}
+
+ docinto ppthtml
+ dodoc ppthtml/{ChangeLog,README,THANKS}
+
+ docinto xlhtml
+ dodoc -r xlhtml/{ChangeLog,README,THANKS,TODO,contrib}
+}