summaryrefslogtreecommitdiff
path: root/app-text/xchm/xchm-1.36.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-19 17:09:22 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-19 17:09:22 +0100
commit590c04803f88a968b4a750c0f420eb314e1fe968 (patch)
treea6d2f2550cb2a6ad9254aa1467aef77488ad32ad /app-text/xchm/xchm-1.36.ebuild
parent66d92fc8569d87a09ac014780528dcad2a12b6c6 (diff)
gentoo auto-resync : 19:09:2023 - 17:09:22
Diffstat (limited to 'app-text/xchm/xchm-1.36.ebuild')
-rw-r--r--app-text/xchm/xchm-1.36.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/app-text/xchm/xchm-1.36.ebuild b/app-text/xchm/xchm-1.36.ebuild
new file mode 100644
index 000000000000..ed93e6bfae5e
--- /dev/null
+++ b/app-text/xchm/xchm-1.36.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+WX_GTK_VER="3.2-gtk3"
+
+inherit desktop wxwidgets xdg-utils
+
+DESCRIPTION="Utility for viewing Compiled HTML Help (CHM) files"
+HOMEPAGE="https://github.com/rzvncj/xCHM/"
+SRC_URI="https://github.com/rzvncj/xCHM/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~riscv ~x86"
+IUSE="nls"
+
+RDEPEND=">=dev-libs/chmlib-0.36
+ x11-libs/wxGTK:${WX_GTK_VER}[X]
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}"
+BDEPEND="nls? ( sys-devel/gettext )"
+
+src_configure() {
+ setup-wxwidgets
+ econf $(use_enable nls)
+}
+
+src_install() {
+ default
+
+ domenu "${FILESDIR}"/xchm.desktop
+ insinto /usr/share/mime/packages
+ doins "${FILESDIR}"/xchm.xml
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+ xdg_mimeinfo_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+ xdg_mimeinfo_database_update
+}