summaryrefslogtreecommitdiff
path: root/app-text/xchm/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-text/xchm/files
reinit the tree, so we can have metadata
Diffstat (limited to 'app-text/xchm/files')
-rw-r--r--app-text/xchm/files/xchm-1.23-wx3.0-compat.patch32
-rw-r--r--app-text/xchm/files/xchm.desktop11
-rw-r--r--app-text/xchm/files/xchm.xml7
3 files changed, 50 insertions, 0 deletions
diff --git a/app-text/xchm/files/xchm-1.23-wx3.0-compat.patch b/app-text/xchm/files/xchm-1.23-wx3.0-compat.patch
new file mode 100644
index 000000000000..a9545cf5b568
--- /dev/null
+++ b/app-text/xchm/files/xchm-1.23-wx3.0-compat.patch
@@ -0,0 +1,32 @@
+Description: Fix code to compile with wxwidgets 3.0
+ Drops support for wx < 2.7, which is just not relevant now. And in fact
+ configure.ac checks for at least 2.8.0.
+Author: Olly Betts <olly@survex.com>
+Last-Update: 2014-03-07
+
+--- xchm-1.23.orig/src/chmframe.cpp
++++ xchm-1.23/src/chmframe.cpp
+@@ -265,11 +265,7 @@ void CHMFrame::OnChangeFonts(wxCommandEv
+ enu.EnumerateFacenames();
+ _normalFonts = new wxArrayString;
+
+-#if wxMAJOR_VERSION == 2 && wxMINOR_VERSION >= 7
+ *_normalFonts = enu.GetFacenames();
+-#else
+- *_normalFonts = *enu.GetFacenames();
+-#endif
+ _normalFonts->Sort();
+ }
+
+@@ -278,11 +274,7 @@ void CHMFrame::OnChangeFonts(wxCommandEv
+ enu.EnumerateFacenames(wxFONTENCODING_SYSTEM, TRUE);
+ _fixedFonts = new wxArrayString;
+
+-#if wxMAJOR_VERSION == 2 && wxMINOR_VERSION >= 7
+ *_fixedFonts = enu.GetFacenames();
+-#else
+- *_fixedFonts = *enu.GetFacenames();
+-#endif
+ _fixedFonts->Sort();
+ }
+
diff --git a/app-text/xchm/files/xchm.desktop b/app-text/xchm/files/xchm.desktop
new file mode 100644
index 000000000000..a8842132a170
--- /dev/null
+++ b/app-text/xchm/files/xchm.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Type=Application
+Version=1.0
+Name=xCHM
+Comment=Compiled HTML Help (CHM) file viewer
+Comment[fr]=Visionneuse de fichiers Compiled HTML Help (CHM)
+Icon=xchm
+TryExec=xchm
+Exec=xchm %f
+MimeType=application/x-chm;
+Categories=Office;Viewer;
diff --git a/app-text/xchm/files/xchm.xml b/app-text/xchm/files/xchm.xml
new file mode 100644
index 000000000000..08cb9ca3f4b8
--- /dev/null
+++ b/app-text/xchm/files/xchm.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<mime-info xmlns="http://www.freedesktop.org/standards/shared-mime-info">
+ <mime-type type="application/x-chm">
+ <comment>Compiled HTML Help Format</comment>
+ <glob pattern="*.chm"/>
+ </mime-type>
+</mime-info>